Segmentation Fault (core dumped)

Dear All,

I have now been stuck for 2 weeks.

I am using SNAP (Windows 10), UBUNTU 16.04, Python 2.7.

I have followed the snap2stamps workflow, with successful export to StaMPS format (stamps_export.py).

I think the interferograms look OK in SNAP, but I am inexperienced. One thing I have noticed is that the raw data is “flipped”, meaning it is the mirror image. So I have to “unflip” interferograms using the Range-Doppler Terrain Correction tool in SNAP (i.e. before import to QGIS). But I would assume mt_prep_snap would have no problem with flipped input?

Anyway, I am stuck at mt_prep_snap (below screenshot). Your advice is greatly appreciated.

Thanks,
Mark


The SLC image is provided in zero-Doppler slant-range geometry;

Source

therefore there is no need to unflip your interferograms, by applying Range-Doppler Terrain Correction, because mt prep snap is used these parameters in Slant range,

Take a look at this post Range Doppler Terrain Correction,

Source of the post

Thanks Falah.

However, I am not unflipping my interferograms before mt_snap_prep, so this is not the problem.

This was your case in your first post, that’s why I gave you my previous answer,

As I mentioned before, no needs to this step before or after mt_snap_prep,

In this case are you sure from all your data, are they all in the same orbit, Frame and slice?
Also from your screenshot it seems that you used snap2tamps, Don’t you?

If yes, this mean everything went automatically without checking your results, anyway in case you’re sure from your data,

I suggest to you apply this Script,

Thank you Falah for your response - greatly appreciated.

Please tell me how to confirm same orbit, frame and slice?

To answer your question, Yes I am using snap2stamps, which is successful:



Check up all your SLC image, you could do so, in the same way of selecting master image,

Add all your SLC to the INSAR overview from radar tab Interferometry,

Other issue , in case all in proper form,

What data and how did you export your data from SNAP after applying SNAP2stamps?

Hi Falah,

I followed your advice and used Stack Overview (below - tracks are the same, but I cant see orbit, frame or slice as you suggested). Then I repeated snap2stamps using the recommended master, but I get the same error when I run mt_prep_snap (below):


I was thinking that you have many images that’s why I gave this option,

But anyway since you have only 5 images it’s easy to check up each one from metadata,


Also I asked you before

Accordingly you should have these two highlighted products, and then export to Stamps

Did you add the elevation and Lat\Lon to each interferogram?

The last note 5 images are too low for PSI application,

Thanks Falah.

I only have five images to experiment - I want to get past the Segmentation Fault problem.

As you suggested, I have now checked REL_ORBIT, slice_num and PASS, and they are equal for all my data.

To answer your questions, I use snap2stamps python scripts before mt_prep-snap:

  1. Sort the slave images in separated folders corresponding to their acquisition time.
  2. Slave splitting (and slice assembling if needed) and annotated orbits replacement with Precise/Restituted Orbits.
  3. Coregistration and interferogram generation done per slave and subswath. Both amplitude coregistered master-slave stack and interferogram with elevation and orthorectified latitude and longitude coordinates are saved as output.
  4. StaMPS export is done providing for each pair coregistered stack and interferogram generated StaMPS compatible products.

snap2stamps python scripts:

slaves_prep.py – script for sorting slaves into the expected folder structure
splitting_slaves_logging.py – script for slave splitting (and assembling if needed) and orbit correction
coreg_ifg_topsar.py – script for master-slave coregistration and interferometric generation
stamps_export.py – script for ouput data generation in StaMPS compatible format for PSI processing

My data before snap2stamps:
Master:
S1B_IW_SLC__1SDV_20180610T070627_20180610T070654_011307_014C2F_4E9C.zip

Slaves:
S1B_IW_SLC__1SDV_20180105T070624_20180105T070652_009032_01023E_622A.zip
S1B_IW_SLC__1SDV_20180306T070623_20180306T070650_009907_011F06_ABCE.zip
S1B_IW_SLC__1SDV_20180902T070631_20180902T070659_012532_0171ED_5143.zip
S1B_IW_SLC__1SDV_20181207T070632_20181207T070700_013932_019D90_36B2.zip

My data after snap2stamps:





Thank you again for you assistance!

Happy that you solved your problem, the reason behind my question is , to clarify and try up to put you on the line of solving the issue.

Hi Falah,

Unfortunately I have not solved the problem. In my last post I provided the information you asked for.

The Segmentation Fault occurs when I run mt_prep_snap. Sorry for the confusion.

Mark

Sorry for that, but there is an option, could be done, since you have only six images, I think it is easy to apply all the steps manually, to checking up the proper result of each one, and then rerun mt_prep_sanp

I solved the issue by formatting my hard drive and reinstalling LINUX. Thanks again for your assistance.

So happy to hear that :smiley:, it also good to take in the future consideration the effect of LINUX on the processing,

Which LINUX did you install in your machine?