Workflow between SNAP and StaMPS

Easy idea for a good result :wink:

It works and it seems ok. we will see if I have some problems in StaMPS.

Thank you very much.

Hi ABraun,
sorry to bother you again but I need help with mt_prep_snap command.

I am using UbuntuWSL and I installed Matlab 2018a for Linux. But in my laptop I have also installed Matlab 2020a for Windows.
When I run mt_prep_snap I have the following error:
"/usr/local/StaMPS-4.1-beta/matlab : permission denied

I checked what happens when I run “source StaMPS_conf.bash”. As shown above, StaMPS open Matlab 2020a (that installed on Windows).
I don’t know how to tell to StaMPS to select Matlab2018a because I cannot modify manually the path, as for StaMPS and Snaphu.

Do you know how to fix this problem? and do you think this is my problem?


I am not sure what causes this error but have you tried to modify the permissions for this folder?

Thank you but it cannot solve my problem.

I must find a way to let StaMPS choose the correct Matlab.

Hi again,
I solved the problem about Matlab but now when I run mt_prep_snap i have the following error:

Can you help me?
Thank you very much in advance

Actually, this error (segmentation fault) already occurred in your post above.
In other cases this error was resolved by reinstalling the operating system:

Maybe you can ask a local system administrator to help you with this.

1 Like

Oh thanks.
I did not notice that post.

So I guess I should reinstall Linux =(


Is it possible to integrate gaps in a time sequence of PS analysis? How big can the information gap be (1, 2 or 6 months)?

I see no problem in such inconsistencies, als long as you consider this gap when you interpret and discuss your results.

ABraun, thank you for your answer.

I reinstall Linux, Matlab, … (everything) but the problem persists.

Can someone help me please?

I’m not sure, but it can be a memory problem, I would recommend you to install ubuntu 18.04, for example in Oracle VM virtual box and install last Matlab granting read and write permissions where you do it (chmod 777 -R ./Matlabins). I use this version and it works perfectly.

1 Like

I will try to do it.

The segmentation fault error was resolved by reinstalling the operating system:

Good afternoon, I have a problem executing mt_prep_snap in ubuntu 20.04, I am already re-related to the stamps working process and I have never had this problem, in ubuntu 18.04, only I changed computer and I had to redo everything again. I have installed the two versions of stamps and on both I get that error.
I think I have installed everything correctly but I get that error, please someone could help me. Beforehand thank you very much.

Maybe you should set more patches according to the size of the image, not just one.

The StaMPS/MTI manual recommends that the number of pixels per patch should be <5 million.

I tried and nothing, I can’t explain what’s going wrong :frowning:

the issue is the compiler.
please try with gcc older, like in the one provided in Ubuntu 18.04.
This will solve your problem.


Thank you very much, if I am just using 20.04, I still had no problem with Ubuntu 18.04

1 Like

good afternoon.
I have a question, in step number 5 of StaMPS, what does it mean to make the consistency check with the visual scanning of the phase of each interferogram; relative to the estimated output of standard deviation?

This step I just did not understand the concept of verification since I do not know exactly what is a correct value to be able to compare them.