Workflow between SNAP and StaMPS

I selected both VV and VH.
I thought it would be better to detect PS.

This is a screen of the interferogram image


actually, the phase is quite similar (or even worse: Effect of polarization on interferometric products), and PSI will only use one either.

I’m not entirely sure if this caused the error, but it would spare you a lot of disk space and computing. And the error message somehow indicates that there are products with the same name, so it could be because of VV and VH are of the same date.

1 Like

Thank you very much, especially for the quickly responds.

I will try to compute the images with just one polarisation.
I hope it will work.


I am pretty sure it is related to the polarization, because after conversion to the gamma format, the products are named


No polarization is part of the file name. Accordingly, both VH and VV would result in the same output file, which probably caused the error message.


I will try to process one polarisation at a time.

Do you know if it is possible to separate VV and VH data after the deburst (and subset) and before the interferogram formation?
I could not find the option to select VV or VH, as in the deburst command.

Should I run again the deburst twice?


I’m not sure if it works after debursting, but you can test Raster > Data Conversion > Band Select

1 Like

Thanks, it works for the stack-image but not for the interferogram one.

1 Like

too bad. How about simply deleting all VH bands from the interferogram stack and saving it?

Would be worth a try before recalculating the entire stack.


Easy idea for a good result :wink:

It works and it seems ok. we will see if I have some problems in StaMPS.

Thank you very much.

Hi ABraun,
sorry to bother you again but I need help with mt_prep_snap command.

I am using UbuntuWSL and I installed Matlab 2018a for Linux. But in my laptop I have also installed Matlab 2020a for Windows.
When I run mt_prep_snap I have the following error:
"/usr/local/StaMPS-4.1-beta/matlab : permission denied

I checked what happens when I run “source StaMPS_conf.bash”. As shown above, StaMPS open Matlab 2020a (that installed on Windows).
I don’t know how to tell to StaMPS to select Matlab2018a because I cannot modify manually the path, as for StaMPS and Snaphu.

Do you know how to fix this problem? and do you think this is my problem?


I am not sure what causes this error but have you tried to modify the permissions for this folder?

Thank you but it cannot solve my problem.

I must find a way to let StaMPS choose the correct Matlab.

Hi again,
I solved the problem about Matlab but now when I run mt_prep_snap i have the following error:

Can you help me?
Thank you very much in advance

Actually, this error (segmentation fault) already occurred in your post above.
In other cases this error was resolved by reinstalling the operating system:

Maybe you can ask a local system administrator to help you with this.

1 Like

Oh thanks.
I did not notice that post.

So I guess I should reinstall Linux =(


Is it possible to integrate gaps in a time sequence of PS analysis? How big can the information gap be (1, 2 or 6 months)?

I see no problem in such inconsistencies, als long as you consider this gap when you interpret and discuss your results.

ABraun, thank you for your answer.

I reinstall Linux, Matlab, … (everything) but the problem persists.

Can someone help me please?