Workflow between SNAP and StaMPS

I’m not sure, but it can be a memory problem, I would recommend you to install ubuntu 18.04, for example in Oracle VM virtual box and install last Matlab granting read and write permissions where you do it (chmod 777 -R ./Matlabins). I use this version and it works perfectly.

1 Like

I will try to do it.

The segmentation fault error was resolved by reinstalling the operating system:

Good afternoon, I have a problem executing mt_prep_snap in ubuntu 20.04, I am already re-related to the stamps working process and I have never had this problem, in ubuntu 18.04, only I changed computer and I had to redo everything again. I have installed the two versions of stamps and on both I get that error.
I think I have installed everything correctly but I get that error, please someone could help me. Beforehand thank you very much.

Maybe you should set more patches according to the size of the image, not just one.

The StaMPS/MTI manual recommends that the number of pixels per patch should be <5 million.

I tried and nothing, I can’t explain what’s going wrong :frowning:

the issue is the compiler.
please try with gcc older, like in the one provided in Ubuntu 18.04.
This will solve your problem.


Thank you very much, if I am just using 20.04, I still had no problem with Ubuntu 18.04

1 Like

good afternoon.
I have a question, in step number 5 of StaMPS, what does it mean to make the consistency check with the visual scanning of the phase of each interferogram; relative to the estimated output of standard deviation?

This step I just did not understand the concept of verification since I do not know exactly what is a correct value to be able to compare them.

I guess that you can do ps_plot(‘w’,1) and compare what you got in the original interferograms.

basically to see if the ifg look noisy or not.

May I ask if you have solved the problem?

Dear all
I am using 17 SENTINEL-1 SLC products for PSInSAR. Until StaMPS’s step 4 my processing was going on well. But when " step 4 - PS weeding"- starting this type of error coming… Did anybody face same problem? Please let me know the reason of this error. Thank you all.

Error using ^
Inputs must be a scalar and a square matrix.
To compute elementwise POWER, use POWER(.^) instead.
Error in ps_weed(line 321)
Error in stamps(line 174)
I used the stamps_v3.3b1 and mt_prep_gamma commands
please kindly guide me with this issue…
@ABraun @mdelgado

@thho @katherine

Have you solved this problem yet, would you please tell me what is the problem?

Please use the last stamps version from GitHub v4.1b

I have one error in StaMPS step6 when I run stamps(6,6). “Error in uw_stat_costs”
I don’t konw how to solve it now. Who kown how to deal with it ? Please give me some advice to solve this problem.

Did you compile snaphu in advance? It is required for unwrapping.

After I run mt_prep_snap command, “snaphu.out” file is not generated.But other file related files are generated .I don’t konw why

2020-08-24 21-44-24屏幕截图

Can you show me how to compile snaphu in advance?