Workflow between SNAP and StaMPS

ok ,I’ve neglect reading this meterials before,thank your mention!

Hello all,

I hope everyone is safe!

When I try to give ‘stamps(2,2)’ command in MATLAB, I am getting error in lines 55 and 190 (Matrix dimensions must agree). The error is in using the ‘/’ command. I tried to use ‘./’ instead on ‘/’, but it did not work. Can anyone please help me solve this problem?

Thank you!

Is there somethong wrong with my process as the notices is “PS_EST_GAMMA_QUICK: Estimating topo error…”

this is fine. It says that it is not estimating the error which comes from the topography (DEM) on the phase. Please check these terms in the manual or these slides:

Are there more images ,more accuracy about PSI?

1 Like

more images lead to a more robust selection of stable scatterers and therefore less variation in temporal analyses. But for single master approaches, longer time series also lead to less persistent scatterers.

1 Like

Thanks for all the informations provided here I could finally get some preliminary results with stamps in windows susbsytem for linux.

but i faced some difficulty in visualization part. First, I tried the vistamps. However, as I am wrking with the latest version of stamps. There seems to be a incompatibility between them that results in errore in maltab. I found out that there is another code based on R, but my question is do I have to install it in ubuntu or I can use it in windows just by working on the outputs that I got from stamps. I also couldnt finde the latest update of that platform. I went to gitub, I couldnt fiqured out what is going on there. I really aprreciarte if someone helps me with that.

I also got a good results from SARPROZ platform. I like to compare the results.


1 Like

you should be able to visualize the results on another machine when you copy the working directory there and have matlab installed. All you need to do is to download the latest StaMPS version and add the directory to the matlab scripts to the Path in Matlab:


Thanks for your prompt response. I already use the latest version and I have the matlab installed in ubuntu. I went torough the manual of matlab. There is only one page for plotting and I could just get the results from ps_plot(‘w’) and the other one for velocity.

you find more explanations in the script file:

1 Like

thank you so much

Thansk for your help ABraun.


Dear FJSarmin,

Your problem of Alos Palsar in StaMPExport step is solved ? Im using the dataset of alos palsar 1.1, and facing the same problem.

Can someone please help with this error in the second step of StAMPS.
which says reference to non existent field
error in ps parms default line 94
error in getparm line 14
error stamps line 53

I have not encountered this problem, but you can refer to the tips in the link below.!searchin/mainsar/non$20existent$20field|sort:date/mainsar/9LASOyFGHIA/RVC18ritAwAJ

In short, the possible reason is that the size of the patch is too large.
Possible solutions:
open MATLAB: Preset >> General >> MAT-Files and click MATLAB Version 7.3 or later.
Set more patches when executing the mt_prep_snap command

If the above methods works, please let me know.

1 Like

Thanks a lot for your valuable comment and suggestion it works!

@thho @ABraun Hi How are you ? I Hope you guys always in Healthy condition…I have a little question about the unit of velocity in PsInsar…PsInsar using mm/year to estimate the velocity of displacement…

Case 1 :
assumed that I’m using Sentnel 1 data from 2017 - 2019 with 15 scenes of satellite imagery, and I’ve got the result velocity in mm/year…

Case 2:
Assumed that I’m using sentinel 1 data from April 2019 - September 2019 with 15 scenes satellite imagery…and also I’ve got the result velocity in mm/year…

Question :
How come the unit velocity in Case 2 is mm/year if my data only span within 6 month??..why is it not mm/month??..
Please explain the logic…:pray::pray:
Thank you in advance

Hi Katherine,
I have the same problem. After having done:
TOPSAR-Split + apply-orbit-file to each image
Back-Geocoding of 25 images
interferogram with tophoPhaseremoval (+ selecting “output elevation” and “output orthorectified lat/lon”)

I tried to do StaMPS export with the stack image and the interferogram one but I have the following error:

How did you solve your problem? Can you help me?

Thank you

have you selected VV polarization in TOPS Split?