SNAP - StaMPS Workflow Documentation

@ABraun You are to kind to everybody trying to get started here, a real hero!

I second your point that he best way to start is just to read through all information sources noted in the StaMPS - Detailled instructions thread.

If anyone has questions about my documentation the best way to contact me is via email, I no longer do InSAR things because I finished my thesis but am still happy to help.

Best regards,


thank you for your kind message - happy to hear that. I see that the materials you and Matthias provided were really filling a gap, so I’m convinced that they already helped hundreds of people.

1 Like

really I dont’ know where is the fault, I did the change you gave me (A Braun) )but the problem is still remain . yesterday I processed my data in snap one more time i did a new export from snap to stamps but the same problem.
i hope that you can see what i can not see. thank you a lot.

Its sad that my thesis was never published then there was a possible reference for it, now i just see it as help and dont know how people would be able to reference an unpublished thesis.

Happy that it helped so many people!

is it an option to put it on ResearchGate or Zenodo, for example, so it gets an own DOI and is officially citable?

1 Like

did you see this post? Segmentation Fault (core dumped)

I’d like to add kudos to @thho here as well. Thorsten’s notes were really helpful for me, too, and most of my guides is based - among others - on elaborations by Thorsten.

Personally, I think that both the topic of PSI/SBAS and the software implementation are quite difficult to get into due to the obvious complexity of what is going on there. To be honest I struggled quite a bit when starting out with StaMPS, even more so since I have no background in microwave remote sensing.

I can only advise everybody to not let yourself get dragged down if things don’t work out of the box. Read the official documentation as well the material provided in this forum as well as in the StaMPS/MTI Google Group. Try to understand what the single processing steps do, and how the workflow works. If you run into problems, please remember to ask concise questions (I really like to reference the Stack Overflow Guide: How do I ask a good question? in that matter). There are really helpful guys here in the forums (most notably @ABraun), but please do not overstrain their willingness to help.


And I fully second that suggestions, both options are viable.

Hi @Naima you need to provide the full path to the INSAR_20200107_data. I have had this error too and using full path has solved it. Note that you should also start the command in that folder, so I would advise to use first:
cd /your/path/INSAR_20200107_data
and then run the command:
mt_snap_prep 20200107 /your/path/INSAR_20200107_data 0.4 3 2 50 200

In linux you can save typing using the $PWD variable:

$ cd /your/path/INSAR_20200107_data
$ mt_snap_prep 20200107 /your/path/INSAR_20200107_data 0.4 3 2 50 200


$ mt_snap_prep 20200107 "$PWD/INSAR_20200107_data" 0.4 3 2 50 200

(quotes added in case /your/path has spaces).


thank you for suggestion, I did but the problem is still. You can see it below.

the version of my gcc is 9.3.0(ubuntu 20.04). I installed gcc 7 and the problem is still. I sourced stamps_config.bash and also stamps_config.tcsh. I ran mt_prep_snap in both shell but the same problem. you can see it below.

after installing gcc 7, you have to install StaMPS again (at best remove it entirely) so it will be compiled with gcc 7 from the beginning.

Dear all, would anyone have any suggestion about the error I reported above?
I would be really very gratefull for any ideas…

Can you figure out which file is affected and if it is correctly stored at the desired location? Try to debug stamps step 1, this error should happen quite at the beginning. The error message is related to textscan being unable to open the data file obtained from snap2stamps and mt_prep_snap. Reasons could be that this file doesn’t exist (at least not at the desired location), or that there are issues with respect to access rights.

Thank you very much for responding. So actually, as expected it was my stupidity… I have moved the INSAR folder after running mt_prep_snap to a different VM. Then I traced back the issue it is of course caused by that because the first part of the path in the rsc.txt is wrong. I have tried to trace the error before but his did not occur to me.

Dear all,
I did it, and it works with gcc7. oh i lost many time in looking for the origin of fault . I would like to thank you all, really I am grateful. now I have another problem, i tried today to work with matlab but nothing works, getparm gives nothing and also stamps(1,1). I changed de working directory to the folder where my data is stocked. must I change something in the configuration of matlab. i let you know that i installed just the trial version R2020b.

it is important that you source the StaMPS_CONFIG script in the command line window and then start matlab with the same window. Only then matlab has access to all the StaMPS scripts, snaphu and triangle: Very recently discussed here: Error in StaMPS Phase unwrapping stamps(6,6)

Thank you Sir it works after many struggles. Problem is facing to me after I finished all the steps when I plot "ps_gescatter(‘ps.kml’,ph_disp,1,0.4,[-10,50],[-98.95,-
98.98],[19.44,19.48]) it does work it gives me ‘’ ps_gescatter(‘ps.kml’,ph_disp,1,0.4,[-10,50],[-98.95,-

Error: Invalid expression. When calling a function or indexing a variable, use parentheses. Otherwise, check for
mismatched delimiters.

An error was encountered opening file /home/mahi/.matlab/R2018a/History.xml
An error was encountered opening file /home/mahi/.matlab/R2018a/History.xml
An error was encountered opening file /home/mahi/.matlab/R2018a/History.xml like this here also with screen shoot pictures.

I will wait your positive and constructive suggestions and comments as usual you all are kind and great persons. Stay blessed.

you have a line break in your command, matlab cannot read this. Please put the entire command in one line