Segmentation Fault (core dumped) error during mt_prep_snap

@ABraun Your solution has been perfect.
Thanks for your help!

Very nice solution.

worked like a charm. thanks

1 Like

It doesn’t work for Ubuntu 20.1

It will work, but Ubuntu 18.04 is very comfortable (as per my suggestion) compared to Ubuntu20.1. And one more advantage of Ubuntu 18.04 is, it will come python2 as a default (snap2stamps code will run only on python2).

It would be helpful to tell us the actual error. Please review the
this thread to see if your issue is covered:

Snap2stamps error - s1tbx / StaMPS - STEP Forum (esa.int)

The problem is installing gcc-7. I did not be able to run StaMPS because I get “Segmentation Fault”. I tried to install multiple gcc compiler, but the older one available for Ubuntu 21.1 is gcc-8.

I’m going to reinstall ubuntu 20.04, I successfully installed multiple gcc compilers on it.

Newer versions of linux distros generally try to support software built using “slightly older” versions, unless the changes that cause your segmentation fault were needed for security reasons. Posting the details of the segmentation fault on an Ubuntu forum may lead to a quick fix (sometimes as simple as
copying a library from an older release to your system).

It is generally not difficult to install older or newer gcc versions from source, so that is generally preferable to doing a full install of an older version.

It may be useful for you.