Python interpreter: DLL load failed


I am using a processor writen in Python in the SNAP GUI. When running the processor I get the following error:

I am on Windows 10 64bit, SNAP, Java, python3.4 are all 64bit.

Does anyone know this error and give me some tips?

It seems that python or jpy is misconfigured. But I can’t say what’s wrong.

I solved the issue:
some python dlls where not contained in the path.
For me it was e.g. libmmd.dll
I added the folder “Library\bin” in the python directory to the path variable and now it works.


Hi, sorry im new in programming lenguage so i don quite understand where did you added the folder “Librari/bin”.
My guess is in DLLs folder in “Anaconda/DLLs”. … or was it at System Variables on SNAP (C:\Users\Cloe\Anaconda2\Lib\site-packages\sen2cor-2.4.0-py2.7.egg\sen2cor), I’ll try this last one, i have the same problem wit a “DLL Load Failed” and i can’t get this to run.

Thanks in advanced


I added the folder to my path variable. In Microsoft you can do this like this:
SET PATH=%PATH%;c:\whatever\else
For me, I added the folder Library\bin directly below the Anaconda folder.
It is necessary to make sure that all python libraries are reachable from the path variable.

I hope I could help.

Thank a lot hganz. I coulnt run sen2core from anaconda. I finally process images with standalone sen2core package. But now a want to run sen2three, as i understand this has to be done from Anaconda, and now i’m getting the same error as before (with sen2cor):

(C:\Users\Cloe\Anaconda2) C:\Users\Cloe>l3_process --resolution 10 C:\CS\Sentinel2A_VTC\1\S2A_MSIL2A_20170223T165311_N0204_R026_T14QPF_20170223T165747.SAFE
Traceback (most recent call last):
File “C:\Users\Cloe\Anaconda2\Scripts\”, line 11, in
load_entry_point(‘sen2three==1.1.0’, ‘console_scripts’, ‘L3_Process’)()
File “C:\Users\Cloe\Anaconda2\lib\site-packages\”, line 570, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “C:\Users\Cloe\Anaconda2\lib\site-packages\”, line 2751, in load_entry_point
return ep.load()
File “C:\Users\Cloe\Anaconda2\lib\site-packages\”, line 2405, in load
return self.resolve()
File “C:\Users\Cloe\Anaconda2\lib\site-packages\”, line 2411, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “C:\Users\Cloe\Anaconda2\lib\site-packages\sen2three-1.1.0-py2.7.egg\sen2three\”, line 13, in
from L3_Library import stdoutWrite, stderrWrite
File “C:\Users\Cloe\Anaconda2\lib\site-packages\sen2three-1.1.0-py2.7.egg\sen2three\”, line 6, in
from PIL import Image
File “C:\Users\Cloe\Anaconda2\lib\site-packages\PIL\”, line 56, in
from . import _imaging as core
ImportError: DLL load failed: No se puede encontrar el módulo especificado

I’ll try adding the folder containing dll on the path variable and see if this works.

Thanks again