RADARSAT-2 product read issue RSTB 7.5.2

I am trying to read RADARSAT-2 data product from SNAP>File>Import>SAR Sensor>RADARSAT-2. But it is giving some error:

java.lang.NoClassDefFoundError: Could not initialize class ucar.nc2.iosp.hdf5.H5iosp

where did you get the data from and in which format, image mode and product level?

When I test with data from here (Extended High Mode, SGF product), I go to File > Import > SAR Sensor > RADARSAT-2 and then select the “product.xml” file

This loads the image correctly.

Thank Braun. I tried with the latest updated SNAP (with new plugin updates), then it is not working. Previously it was working.

Have you installed all updates?


Still: Where did you get the data from and in which format, image mode and product level?

Yes, I have installed the available updates, from this Check update menu.

I am also using the Vancouver image (RADARSAT-2) which you have mentioned above. But, still issues are persistent .

maybe the data was not fully downloaded or extracted?
The folder Vancouver_RS2_Extended_High1_HH_SGF should have
56 files
68,1 MB

I tried with other SLC products of RADARSAT-2 too, but not working. Same thing I tried before the updates, it was working that time. I guess there is some issue with the toolbox update happened today.

I also tested before and after the update and no error occurs. Have you restarted SNAP after the update?

It is possible that something in your update failed. To go sure you can uninstall SNAP, install it again and then re-run the update.

Thanks Braun. I reinstalled the SNAP version, and now it is started working fine. I thing during java updates, some issues happened. Thanks for your time.

1 Like