Release of Sen2Cor 2.11

Originally published at: Release of Sen2Cor 2.11 – STEP

We are pleased to inform the Sentinel-2 users community that a new version of Sen2Cor (Release 2.11) is available under: Sen2Cor v2.11 – STEP. This new version supports the current update of Sentinel-2 products with Processing Baseline 05.09. Stand-alone installers for the two operating systems Linux, and Windows are now on-line. All two versions require a 64-bit platform.…

1 Like

Dear all,

unfortunately, I have massive problems while installing/using the standalone version of sen2cor 2.11. I get lots of messages like “no module named ‘skimage’” (this happened for at least 5 other packages, too) and code errors (I assume Python 2.x was used?!). Is there anything I did wrong in the installation process or are these errors bugs you need to solve?

I appreciate any helping comments! Thank you!


Additional info: I use Python 3.11. Currently going back to Python 3.10 to see if this changes anything. I’ll keep you posted.

@Amalia-Castro-Gomez can you please take a look?

1 Like

I still could not solve the problem on my own. The change to Python 3.10 didn’t help.
Currently, I can’t fix the error " import topographicshadows_cython_03
ImportError: DLL load failed while importing topographicshadows_cython_03", which is part of
Any advice on this?


I’m sorry but I’m also not familiar with sen2cor.

Maybe @bdpg can help?

I need some more details for trying to help.
On which platform do you like to install Sen2Cor? Windows, Linux or MAC? Information about release/version could also be helpful.
How do you try to install Sen2Cor? Steps, commands, …?

Sen2Cor 2.11 installation was going without problems for me, both on Windows (MS Windows 10 Enterprise) and on Linux (Red Hat Enterprise Linux Workstation version 7.9).

Kind regards

1 Like

We will look into it too and report back, thanks for your patience !

Hi everyone,

I solved it by myself: I called the wrong L2A_Process (.py instead of the batch file). Sorry for the inconvenience and thank you very much for helping me!



I have this error with sen2cor 2.11, i can’t run the L2_process


Please specify the error you receive.

Hello, thanks

This is the error:

/home/lanotadm/LANOT_sentinel2_sargazo/Sen2Cor-02.11.00-Linux64/bin/L2A_Process: 5: /home/lanotadm/LANOT_sentinel2_sargazo/Sen2Cor-02.11.00-Linux64/bin/python2.7: not found

It doesn’t find the python2.7, but there is a file called python2.7 in the bin directory

Thank you for the reply

This error message is somewhat misleading. It’s not that python2.7 is not found, rather the ‘interpreter’ for that binary ld-musl is not.

On my system for example:

/usr/local/sen2cor/bin# file python2.7
python2.7: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib/, stripped

If you run the same command on your system (pointing at the python2.7 binary) you will probably get the same output. Looking on my system /lib/ exists, but only because I copied/symlinked it there from /usr/local/sen2cor/lib/ .

On your system, assuming you have root privileges, you can probably run

ln -s /home/lanotadm/LANOT_sentinel2_sargazo/Sen2Cor-02.11.00-Linux64/lib/ /lib/

I figure that there is probably a way, by setting just the right environment variables, that you can get the system to find the linker without having to copy it to a specific place, but I do not know.

Good luck

1 Like

I should add that I’ve only come across this issue in the context of running sen2cor inside a docker container. I have no experience installing and using sen2cor in any other context.

thank you for the reply, yes i have root privileges, i’m going to try this, thank you

I face the same problem and tried in Fedora 37 (laptop), Ubuntu 22.04 (virtual machine), 18.04 (docker), 16.04 (docker), to no avail.


using Ubuntu docker

root@2a2517c0b77f:/# cat /etc/issue
Ubuntu 18.04.6 LTS \n \l

root@2a2517c0b77f:/# /Sen2Cor-02.11.00-Linux64/bin/L2A_Process
/Sen2Cor-02.11.00-Linux64/bin/L2A_Process: 5: /Sen2Cor-02.11.00-Linux64/bin/L2A_Process: /Sen2Cor-02.11.00-Linux64/bin/python2.7: not found

root@2a2517c0b77f:/# ldd /Sen2Cor-02.11.00-Linux64/bin/python2.7 (0x00007ffd63532000) => not found => not found

set path to private libs:

root@2a2517c0b77f:/# export LD_LIBRARY_PATH=/Sen2Cor-02.11.00-Linux64/lib/
root@2a2517c0b77f:/# ldd /Sen2Cor-02.11.00-Linux64/bin/python2.7 (0x00007ffc4d1bd000) => /Sen2Cor-02.11.00-Linux64/lib/ (0x00007f1732049000) => /Sen2Cor-02.11.00-Linux64/lib/ (0x00007f1731dbc000)

root@2a2517c0b77f:/# /Sen2Cor-02.11.00-Linux64/bin/L2A_Process
/Sen2Cor-02.11.00-Linux64/bin/L2A_Process: 5: /Sen2Cor-02.11.00-Linux64/bin/L2A_Process: /Sen2Cor-02.11.00-Linux64/bin/python2.7: not found

root@2a2517c0b77f:/# /Sen2Cor-02.11.00-Linux64/bin/python2.7 -s /Sen2Cor-02.11.00-Linux64/lib/python2.7/site-packages/sen2cor/
bash: /Sen2Cor-02.11.00-Linux64/bin/python2.7: No such file or directory

On which Linux version does Sen2Cor 2.11 work?

And: when to expect Python 3 support?

For the record: a new 2.11 has been released: