Reporting SNAP Desktop GUI Error (Linux version)

Dear All,
I’m using the latest SNAP 5 desktop version on a Linux desktop (Scientific Linux 7.4, Kernel: Linux 3.10.0-693.2.2.el7.x86_64), and get the following pop-up message error:

each time I try to display or refresh the “Product Library” panel. The products contained in the targeted directories are not displayed.

Thanks for any feedback on this issue,
Best regards,

It’s also reported on Github:

Indeed, I finally found the issue tracker on github to be a better place for this and posted the same message


This strange sign often happens when something is wrong with the encoding of the text which is read.
Can you have a look at the log file after this message occurs? You can find the log files from the menu. Select Help/Show Log Directory. The latest logs are in the file messages.log.
Would be good if you can attach it here. Maybe this gives some insights.

Regarding the issue reporting. It is absolutely OK to post the error here. I think more people follow the forum and get notified about problems and how they can be fixed. The issue tracker on Github is not being followed by so many people.

Here is the messages.log part related to this pop-up event:

INFO [org.esa.snap]: Query=(APP.PRODUCTS.MISSION = ‘Sen3’)
java.lang.NumberFormatException: For input string: “�”
at sun.misc.FloatingDecimal.readJavaFormatString(
at sun.misc.FloatingDecimal.parseFloat(
at java.lang.Float.parseFloat(
at org.esa.snap.engine_utilities.db.ProductEntry.parseGeoBoundaryStr(
at org.esa.snap.engine_utilities.db.ProductEntry.(
at org.esa.snap.engine_utilities.db.ProductDB.queryProduct(
at org.esa.snap.engine_utilities.db.DBQuery.queryDatabase(
at org.esa.snap.productlibrary.rcp.toolviews.DatabasePane.queryDatabase(
at org.esa.snap.productlibrary.rcp.toolviews.DatabasePane$1.valueChanged(
at javax.swing.JList.fireSelectionValueChanged(
at javax.swing.JList$ListSelectionHandler.valueChanged(
at javax.swing.DefaultListSelectionModel.fireValueChanged(
at javax.swing.DefaultListSelectionModel.fireValueChanged(
at javax.swing.DefaultListSelectionModel.setValueIsAdjusting(
at javax.swing.JList.setValueIsAdjusting(
at javax.swing.plaf.basic.BasicListUI$Handler.mouseReleased(
at java.awt.AWTEventMulticaster.mouseReleased(
at java.awt.Component.processMouseEvent(
at javax.swing.JComponent.processMouseEvent(
at java.awt.Component.processEvent(
at java.awt.Container.processEvent(
at java.awt.Component.dispatchEventImpl(
at java.awt.Container.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.LightweightDispatcher.retargetMouseEvent(
at java.awt.LightweightDispatcher.processMouseEvent(
at java.awt.LightweightDispatcher.dispatchEvent(
at java.awt.Container.dispatchEventImpl(
at java.awt.Window.dispatchEventImpl(
at java.awt.Component.dispatchEvent(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at org.netbeans.core.TimableEventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(

By the way I get the exact same error pop-up when SNAP launches (and same “java.lang.NumberFormatException” message in logs).

My locale settings are as follow:
System Locale: LANG=en_GB.utf8
VC Keymap: fr
X11 Layout: fr

It seems consistent with the SNAP messages.log header:

System Info:
Product Version = SNAP (Build 201609300101)
Operating System = Linux version 3.10.0-693.2.2.el7.x86_64 running on amd64
Java; VM; Vendor = 1.8.0_102; Java HotSpot™ 64-Bit Server VM 25.102-b14; Oracle Corporation
Runtime = Java™ SE Runtime Environment 1.8.0_102-b14
Java Home = /home/jerome/snap/jre
System Locale; Encoding = en_gb (snap); UTF-8

Hope this helps, let me know if you need more logs

You could try the preview version of SNAP 6. A lot has changed regarding the Product Library here. So it might have bee solved by the new version. Another reason could be that there is a corrupt product which has a bad character.
Or something was not correctly written into the product database.
You could try to remove the products from the DB and add them again.

@junlu Whatt do you think could be the cause?

I first tried to remove any products from my data directory using SNAP 5, and the pop-up keeps showing. Not related to a bad product.

I then remove SNAP 5 and installed SNAP 6 preview, and I unfortunately get the same issue (logs below):
log.txt (69.0 KB)

I’ve moved the long log into a text file, for better readability of the thread.

I tried to populate the Product Library with several S3 products and I noticed that it is not working well. But I haven’t seen your specific error.
After scanning a directory, it was said that several products could not be read. Might be true for some of them because they are from old Test Data Sets. But at least most of them can be opened in SNAP without any problem.
The error:

Product unreadable   G:\EOData\SENTINEL\SENTINEL3\OLCI\S3A_OL_1_EFR____20161023T100950_20161023T101250_20161023T120602_0179_010_122_1979_SVL_O_NR_002.SEN3\xfdumanifest.xml

And the product opened in SNAP:

In addition, after the scan, the UI of the Product Library wasn’t reactive anymore:

Maybe caused by such exception:

at javax.swing.CellRendererPane.paintComponent(
at javax.swing.plaf.basic.BasicTableHeaderUI.paintCell(
at javax.swing.plaf.basic.BasicTableHeaderUI.paint(
at javax.swing.plaf.ComponentUI.update(
at javax.swing.JComponent.paintComponent(
at javax.swing.JComponent.paint(
at javax.swing.JComponent.paintChildren(
at javax.swing.JComponent.paint(
at javax.swing.JViewport.paint(

I’ve used the latest code from GitHub. Which is almost equivalent to SNAP 6 preview5.

@cwong Can you check this?