Run sen2cor: ERROR "No module named glymur”

I have problems when running sen2cor: ERROR “No module named Glymur”.

I read previous topics here, but not resolved!

I changed the directory path of python in sen2cor tools:
Manage external tools -> sen2cor -> edit -> system variables -> And Then change the python.exe to the c: \ users \ [yourname] \ Anaconda [version number] \ python.exe

but not resolved! =/

I appreciate if someone help!

can you post a screenshot of your system variables under external tools?

please type pip list in your command line and see if glymur is listed.
If not, type pip install glymur

I type ‘pip list’, I think that is not installed, then i type ‘install glymur’, but not it is not recognized as an internal command:

it is pip install glymur

oh sorry! now i type ‘pip install gymur’ and… new error! =/

try conda install glymur

the unicode error indicates that the ã in your user name causes conflicts of string coding.
I don’t know how to fix it but you will surely find answers in the Anaconda help.

Good suggestion, @unnic!

I thought the ‘ã’ would cause problems. I changed to’a’ in name user, but in the cmd continues ‘ã’. I do not know why. Now I tried ‘conda install glymur’ and appeared a new error. I typed ‘anaconda search -t conda glymur’ and do not know which option I choose. Can you help me please?

you could try also conda update glymur

did you run conda update conda and conda update anaconda ?

now there is an error message, as I understand it is about the connection. But I’m online! LOL =/. I’ll try to go through it, and I will give you a return. Thank you for your help unnic


are you running it from inside a virtual machine?

I try conda update conda and conda update anaconda, and installed! ok! =D but conda update glymur and conda install glymur, not! error again…

Now, i unnistalled the SNAP, Anaconda2 and sen2cor, and reinstalled again… On two different machines, but there were errors in the installation. The program opens, but errors occur "No module named glymur " Thanks, ABraun and unnic, but for now I give up!


I had the same problem with module glymur and this has worked for me:

Thank you for this.
I download glymur, but how can i use? Please teach me.