Running sen2cor docker using image from docker Hub

I would like to create a docker container regarding sen2cor. Many images are available at docker hub. I am new to docker and I am stuck at this point. I use “dymaxionlabs/sen2cor” image which is available at docker hub. I am able to run the container. Firstly, I ran the following command.

docker pull dymaxionlabs/sen2cor

Then I created a docker-compose file:

version: ‘3.5’

    image: daviddemeij/sen2cor:2.0.9
        - C:/Users/tensorflow/Desktop/Ilias_dockering_draft/docker_sen2cor_V2:/data
        - C:/Users/tensorflow\Desktop/Ilias_dockering_draft/docker_sen2cor_V2/output:/output
    command: /data/S2A_MSIL1C_20211229T101431_N0301_R022_T33UXA_20211229T110526.SAFE --resolution 20 --output_dir /output

Afterwards, I ran docker-compose up and it worked.

I would like to use the latest version of sen2cor but is not supported at this image (dymaxionlabs/sen2cor). I tried to change the image of docker-compose (yml) file from

image: daviddemeij/sen2cor:2.0.9


image: sen4x/sen2cor:2.10.01-ubuntu-22.04

but it did not work out.
What can I do it to fix it? Should I use another approach?

Thanks in advance!