Running sen2res on MacOS (Sonoma 14.4.1) - Using SNAP 10.0.0

I’ve tried to run sen2res on my Mac mini (M2 Pro, 12 cores, 32 GB RAM) & it seems to run initially since it adds the new layer to the Product Explorer window, but when I try to open it as RGB it gives an error pretty quickly rather than running for a long time as it does on Windows. I have tried running sen2res on a Sentinel 2A MSI (level 2A product).

Has anyone had luck using it on MacOS? I have a virtual Windows 11 machine, but since it’s doesn’t get all the resources of my Mac it’s really slow for this intensive process. I’d love to run it on the MacOS because it’s such a big job. Any insights would be great. Thanks!

Error messages below:

  1. SNAP - Error: The RGB image could be created.
  2. Unexpected Exception: Java.lang.RuntimeException: Waiting thread received a null tile
  3. Unexpected Exception: A java.lang.NoClassDefFoundError exception has occurred. (includes link to whole error log).
  4. Unexpected Exception: A java.util.concurrent.ExecutionException exception has occurred. (includes link to whole error log).

Dear @MaryHenryGEO,

The 1.1 version of Sen2Res is only compatible with Linux and Windows 32 or 64 bits:

1 Like

Thank you for the reply, @diana_harosa!
That would explain the problem then. I wonder why it’s even there as an available plugin in the Mac version at all. Guess I won’t get to find out how fast my Mac mini could run it then. :wink: