S-1 Enhanced Spectral Diversity error: "A problem occured during the target product processing"

I am trying to replicate the RUS Webinar “Land Subsidence mapping with Sentinel-1” on a pair of S-1 images, both images are IW-SLC, same track (but different orbit) and both descending. I am running SNAP 7.0 on Ubuntu 18.04 and I have 35GB free space. I have succesfully applied ‘Apply Orbit file’ and then ‘S-1 Back Geocoding’ but when I try to apply ‘S-1 Enhanced Spectral Diversity’ I get the following error, which is not solved even if I tried to tweak the parameters:

A problem occured during the target product processing
Type: OperatorException
Message: 0
Screenshot from 2020-01-27 15-42-54|690x209

Here is the full error report:

java.lang.ArrayIndexOutOfBoundsException: 0
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.outputESDEstimationToFile(SpectralDiversityOp.java:1328)
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.estimateAzimuthOffset(SpectralDiversityOp.java:778)
Caused: org.esa.snap.core.gpf.OperatorException: 0
at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:415)
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.estimateAzimuthOffset(SpectralDiversityOp.java:783)
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.computeTileStack(SpectralDiversityOp.java:457)
Caused: org.esa.snap.core.gpf.OperatorException: 0
at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:415)
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.computeTileStack(SpectralDiversityOp.java:483)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(OperatorImageTileStack.java:116)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(OperatorImageTileStack.java:85)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
Caused: org.esa.snap.core.gpf.OperatorException: 0
at org.esa.snap.core.gpf.internal.OperatorExecutor$GPFImagingListener.errorOccurred(OperatorExecutor.java:376)
at com.sun.media.jai.util.SunTileScheduler.sendExceptionToListener(SunTileScheduler.java:1646)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:921)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at javax.media.jai.PlanarImage.getData(PlanarImage.java:2085)
at com.bc.ceres.glevel.MultiLevelImage.getData(MultiLevelImage.java:64)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:407)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:393)
at org.esa.snap.core.gpf.internal.OperatorImage.computeRect(OperatorImage.java:73)
at javax.media.jai.SourcelessOpImage.computeTile(SourcelessOpImage.java:137)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at com.sun.media.jai.util.RequestJob.compute(SunTileScheduler.java:247)
[catch] at com.sun.media.jai.util.WorkerThread.run(SunTileScheduler.java:468)

how many bursts have you selected during TOPS Split?

Just 1, my whole study area is within a single burst.

ESD corrects shifts between multiple bursts. If you only have one, you cannot apply it.

1 Like

A problem occurred during the target product processing. Type: OperatorException Message: Executor already shutdown!!
Anyone knows something about this error, while ESD operator,

  • Zoran
1 Like

I had same problem too. Did you find some decision? In my case I have two bursts but it is still not work.

I uninstalled last updates from SNAP, or reinstall Snap without applying updades,

  • Zoran

I am also facing the same issue with ESD in SNAP 7.0.

I still haven’t found a solution. If you will find this, please let me know. Thanks in advance!

@jun_lu Was the ESD operator changed recently? I don’t have an explanation for the “Executor already shutdown” error.

ESD operator has not been changed since Feb, 2020. I’ll look into the issue to see what caused the problem

1 Like

I have selected 3 bursts during S1TOPS split and successfully applied orbit files then back geocoding. I can’t proceed beyond the enhanced spectral diversity step. Should I reinstall snap?

I installed SNAP 8.0 and operated split on 2 different images, in orbit step I faced an error of operator exception. I found solution in forum and after snap update this problem fixed. now, in ESD step I faced again with the same problem. How can I fix it? 2 months ago, I used SNAP 8.0 and I have any problem with it.

Please select 2 burst and use snap6.0. Dont forget changed dem file http in snap.auxdata.properties

SNAP6 is no longer supported and quite outdated by now. Please upgrade…

i steel have the same problem

How many bursts did you select during TOPS Split?

I selected two bursts

Are you working with SNAP 8 including all updates?