S1 Backgeocoding Error


I have been trying to co-register two tiles of S1-TOPS data using S1 backgeocoding tool in SNAP 8.0, the processing gets completed smoothly without any error. However, when I open the slave image it has NaN values.
I tried using SNAP 7.0 also but the same result.
I tried changing master and slave bands but always the slave image shows NaN values with min and max values of 0.0 and 4.9E-324 respectively.

Any help would be appreciated @ABraun @jun_lu @mengdahl @marpet

Thanks and Regards

An empty band after BackGeocoding means that the coregistration failed. Did you install all updates?

can you please share the product IDs?

Sorry for delayed reply,

Yes I installed all the updates and tried again but the result is same

The Product ids are:

have you reduced the subswaths during TOPS Split to the same area?

Yes, 21001 * 5972 pixels in both products after doing TOPS split

can you plase share a screenshot of the two input products for BackGeocoding and which preprocessing you applied so far?

S1 TOPS Split ----> Apply Orbit File -----> S1 Back Geocoding

did you open them and visually check for valid data?

Master Image is fine and pixel values are valid

Slave image shows NaN pixel vlaues

Sorry, I meant before the coregistration

Yes, the data is valid!

I checked after subsetting to small area also, but the same results.

at which stage did you apply the subset? Actually, you shouldn’t apply any spatial subset before the coregistration (and debursting) of the images when working with SLC data

I tried coregistration by subsetting the data and without subsetting the data also.

The processing steps employed are as:

  1. SLC image —> S1 TOPS split —> Apply Orbit file —> S1 Backgeocoding

  2. SLC image —> S1 TOPS split —> Apply Orbit file —> Spatial subset —>S1 Backgeocoding

both pathways yield the same result

this one should work actually, but I’m out of ideas why you receive a partially blank output. Have you tried using another DEM for BackGeocoding? E.g. SRTM 1Sec instead of 3Sec

Yes, i am using SRTM 1 sec

and it is not first time , I have tried corregistration on two SLC tiles for the year 2017 over upper himalayas, there also the error occured. Fore some image pairs it is working, for others it doesnot.

which sub-swath and which bursts did you use in TOPS Split?

Subswath IW3
Burst 4 to 7

I have tried your data with the mentioned steps and configurations and did not receive any error.

1 Like

can you send me the interferogram file, please?

Does it have to do with RAM overload, my machine has 16 GB RAM?