S1 thermal noise removal not working for certain S1 EW scenes


I am trying to run thermal noise removal on EW S1 scenes using the Sentinel 1 toolbox. It has worked for some scenes but one particular scene area results in this error:

Type: OperatorException
Message: computeTileNoiseLut: java.lang.ArrayIndexOutOfBoundsException

I have also tried using SNAP and receive this error:

Type: OperatorException
Message: Cannot construct DataBuffer.

Some of the files that I’ve tried in this area and have received these messages are:



Both my Sentinel 1 and SNAP toolboxes are up-to date.


I have had likely similar problem with many S-1 EW scenes, thermal noise removal is not working as noise vectors in the noise LUT are not same size. I am still using S-1 toolbox 1.1.1 as it allows to use reproject command in gpt-processing for my sea ice SAR images. These do not need terrain or ellipsoid correction now required in later versions.
Error message I am getting is like:
Error: computeTileNoiseLUT: 268

As a solution I am manually editing noise vectors to same size by replicating the last noise LUT value in shorter vectors (they seems to be always just one value shorter) and adding a range pixel value one below the last one, e.g.
… 10480 10481
… 0.000000e+00 0.000000e+00
These noise LUTS are in \annotation\calibration directory

Dont know if this creates any unwanted effects…


Thanks for the report Marko. Since GRD-images are not map-projected, the “feature” you use with S1TBX 1.1.1 is actually a bug, and the geolocalization of your projected products is sub-optimal (= incorrect).

Please use updated SNAP3.0 (or 4.0 that will be available very soon), and do ellipsoid-geocoding directly into the map-projection of your choice.