S1tbx coregistration after calibration

I have a S1_SLC product and first I wanted to calibrate it and second to coregistrate it.
But after the calibration snap showes:
“Error in graph: [Nodeld: Back-Geocoding] Input should be a songle look complex SLC product”
My question is can I do calibration and coregistration together?

Best regards

calibration to Sigma0 removes the phase information from your product, so it’s no longer ‘complex’ (as in SLC).
You can however choose: “Calibrate to complex output” in the calibration module. It should be then possible to coregister afterwards.

For an InSAR related application, generally calibration is not applied.

what does the complex calibration option refer to then?

We added it primarily for polarimetric applications. It’s makes a difference for Freeman Durden for example.
If you’re only concerned with the phase then you could skip it but, if you want to work with the intensities in complex datatype then you should calibrate. I guess it will affect coherence but, if both images have the same incidence angles it might not matter.

1 Like

Hi @lveci,
I like to revive this old post. Assume we have a good reason to do calibration before back-geocoding. Currently, we don’t seem able to run this without artifacts. Adding the calibration node before back-geocoding introduces nan-patches in our output all the way after terrain correction. Any suggested way forward to overcome this?


Please give more details about your processing-chain. I suppose you have installed all the updates.