S1TBX new module update to support IPF 2.9 products

The module update has been released, please perform check for updates and restart SNAP to update your toolboxes. Our apologies for the lateness of this fix, there were some major unforeseen circumstances that prevented us from releasing the update in due time.

The update comes with the following release note:

The update includes fixes to support the S1 products after March 13 that have updated noise vectors. Updates have been made to S1 noise removal and S1 slice assembly. For users that want to run both of these operations, they will need to run the noise removal before the slice assembly.

Please test the update and report any issues you might find.

With best regards,


SNAP ESA Technical Officer

After the update, my simple graph running on Linux is crashing. I believe the java null pointer traceback points to SpectralDiversity. I have verified the graph runs after removing the Enhanced-Spectral-Diversity node.

90% done.
org.esa.snap.core.gpf.OperatorException: java.lang.NullPointerException
at org.esa.snap.core.gpf.graph.GraphProcessor$GPFImagingListener.errorOccurred(GraphProcessor.java:363)
at com.sun.media.jai.util.SunTileScheduler.sendExceptionToListener(SunTileScheduler.java:1646)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:921)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at javax.media.jai.PlanarImage.cobbleFloat(PlanarImage.java:3254)
at javax.media.jai.PlanarImage.getData(PlanarImage.java:2181)
at com.bc.ceres.glevel.MultiLevelImage.getData(MultiLevelImage.java:64)
at javax.media.jai.PlanarImage.getExtendedData(PlanarImage.java:2440)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:405)
at org.esa.snap.core.gpf.Operator.getSourceTile(Operator.java:481)
at org.esa.s1tbx.insar.gpf.CoherenceOp.computePartialTile(CoherenceOp.java:958)
at org.esa.s1tbx.insar.gpf.CoherenceOp.computeTileForTOPSARProduct(CoherenceOp.java:892)
at org.esa.s1tbx.insar.gpf.CoherenceOp.computeTileStack(CoherenceOp.java:568)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(OperatorImageTileStack.java:116)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(OperatorImageTileStack.java:85)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at javax.media.jai.PlanarImage.getData(PlanarImage.java:2085)
at com.bc.ceres.glevel.MultiLevelImage.getData(MultiLevelImage.java:64)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:407)
at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:393)
at org.esa.snap.core.gpf.internal.OperatorImage.computeRect(OperatorImage.java:73)
at javax.media.jai.SourcelessOpImage.computeTile(SourcelessOpImage.java:137)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at com.sun.media.jai.util.RequestJob.compute(SunTileScheduler.java:247)
at com.sun.media.jai.util.WorkerThread.run(SunTileScheduler.java:468)
Caused by: org.esa.snap.core.gpf.OperatorException: java.lang.NullPointerException
at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:432)
at org.esa.s1tbx.sentinel1.gpf.SpectralDiversityOp.computeTileStack(SpectralDiversityOp.java:521)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(OperatorImageTileStack.java:116)
at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(OperatorImageTileStack.java:85)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
… 24 more

Error: java.lang.NullPointerException

ProductSet-Reader is not working as input to SliceAssembly after the update. My workaround replaces ProductSet-Reader with two Read nodes for my AOIs that are split between two S1 GRDH frames in a pass.

For the ESD error, it might be caused by the commit https://github.com/senbox-org/s1tbx/commit/49d876fdceb1dfb31d5325984f98e9dd4def661f#diff-5c5e60feab8616c1afed1420222464ac

However, by applying the latest commit https://github.com/senbox-org/s1tbx/commit/c5469b78a6cf01926c79c5d3f426e88455aa6c40#diff-5c5e60feab8616c1afed1420222464ac, it might solve your issue

1 Like

An update for this will be available soon

Stephen thanks for the idea. I took a snapshot of S1TBX v7.0 that includes the commit . I am now able to process graphs with ESD in the GUI on Linux. I still get the NullPointerException running my graph with gpt.

I get ‘Java heap space’ errors when using the thermal noise removal operator for IW GRDH scenes processed after March 13, 2018.
Tested on:

My graph consists of thermal noise removal-> calibration -> terrain correction.
When running the graph on scenes from 2017 from the same relative orbit, the problem doesn’t appear.
Tested on:

Also when I remove the ‘thermal noise removal’ operator from the graph, the processing works fine for the scenes after March 13.

Windows 10, 16GB RAM.
Thanks in advance!

I’m getting the same error.

Although strangely, I’ve noticed that the tool does produce an output file that worked in my next step (Radar | Radiometric | Calibrate).

I didn’t check the results to see if the noise was actually corrected. No problem with pre-March 2018 scenes.

Mar. 28, 2018 I noted a problem with ProductSet_Reader after the upgrade, but failed to notice that my graph no longer had ProductSet_Reader at the start. The ProductSet_Reader works fine as long as it is at the start of the graph.

Dear Thomas, Was your problem solved?

Hi,Iveci. Can you tell me what the instrument processing facility (IPF) is? And how do I install and use it?

The IPF is the Sentinel-1 SAR processor. As far as I know, you cannot get it unless you run a Sentinel-1 Cooperative Ground Station or the Core Ground Segment.

Hi all,
I am facing the problem of Thermal Noise Removal error, on Sentinel 1 scene collected after March 2018.
I have SNAP 8 version and I want to process Sentinel 1 data downloaded from ASF from 2017 to 2019. In 2017 I have no issues in the batch process I run. Starting from March 13th I cannot process the images with the same batch process.
I attached a screenshot of the error that appears when the Thermal Noise Removal Step is run.
Do you have any idea how to solve this problem? I read posts on this topic, related to a few years ago, however, I am still facing this problem which seems not solved. Do you know how can I run the IPF Sentinel1 SAR processor? Or if there are any other solutions? Thanks a lot!!