S3 Multi size mosaic wrong output when used gpt

Hello everybody!
I need some help, I’m working with GPT for processing many files of Sentinel-3 WFR, so I need create a mosaic, I have the xml for the mosaic but the result is an image with a white space, I don’t know why is the problem, so I need help.

I attached my xml and the result.

Thank you!!

Mosaico_G.xml (11.0 KB)


this is a bug in SNAP. Thanks for finding it.
I’ve created a ticket for it:

There is also a workaround. After you did the mosaicking step you can change the valid-pixel expression. Open the context menu of the band and select properties. There change the valid-pixel expression to: CHL_OC4ME < 254
Afterwards go to the Colour Manipulation dialog and recompute (image ) the colour information.
Now the data should be shown correctly.

Also you don’t need to use the multi-size mosaic. The normal mosaic is sufficient for OLCI.

1 Like

Thank you very much! I tried changing the pixel expression but the result shows only values between 0 and 1, like a mask.

I tried to use the normal mosaic option with GPT, but I have the same problem.


Thank you for your help.

Hello! After other attempts with the multi-size mosaic, I changed my XML to use the mosaic option and working fine. I tried with the multi-size because I couldn’t use the mosaic option with some files at the beginning of my work, but finally, the mosaic with GPT it’s run correctly.

Thank you for all your help and development of SNAP; it is amazing.

1 Like