S3 preprocessing xml source bands does not match downloaded product

i am working on the sen-et plugin, but im trying to run it manually through python.

after downloading the sentinel 3 product the next step is the preprocessing.

the source bands in the provided sentinel3 preprocessing xml are not found in the s3 product. the bands in question are (sat_zenith_tn,solar_zenith_tn,latitude_tx,longitude_tx) is there something i am missing ?

the error I’m getting:

rror: [NodeId: Subset] Operator ‘SubsetOp’: Value for ‘Source Bands’ is invalid: ‘solar_zenith_tn’

well this was solved by loading the xml graph to snap desktop, loading an example product, then saving the graph and using it.

I had exactly the same problem… But this is still a problem if you want to call this functionality from python or integrate in some processing chain. Anybody of the SNAP developers that can help us with this?

Can you maybe post the graph xml file?
The names mentioned above are the tie-point grids of SLSTR data.
Maybe the provided xml is not correct.
So they actually should be specified in the tag tiePointGridNames of the subset node:

<graph id="someGraphId">
  <node id="someNodeId">

Hi Marco, thanks for your reply. I actually just took the XML that comes as an example with the plugin. Just changed the paths to my inputs and I get the error when using gpt on the command line. Works ok when used from the GUI.

I attach the graph XML here.sentinel_3_pre_processing.xml (6.3 KB)

loading the xml to snap shows what options you can choose and apparently solar_zenith_tn was not one of these options hence the error.

I ran it as it is from the GUI and worked fine… it’s the command line the problem.

the graph worked from the command line,

but now I’m stuck at the data mining sharpener where the output is always blank, so i don’t know if messed up somewhere.


Anyone found a solution on this issue ? It indeed works fine through SNAP but not with gpt command line… The output_geometry_observation file is empty.
I use the exact same xml provided by the plugin…