S3 SLSTR LST reprojection

Hi everyone,

I am currently using GPT to subset and reproject L2 SLSTR LST nc files. Unfortunately I get important geocoding problems (missing pixels), increasing with latitude. Below are two examples around 66N and 80N, respectively.

Here is the very simple graph I’m using:
S3.xml (1.2 KB)

and the GPT call:

 gpt S3.xml \                                                                                                                                                                  
  -PSLSTRsource=my_source \                                                                                                                                              
  -Ds3tbx.reader.slstr.pixelGeoCoding=false \                                                                                                                                              
  -Dsnap.log.level=ERROR \

Following this issue, it seems turning pixelGeoCoding off should solve the issue but I don’t see any difference…

Thank you a lot in advance for your help!


according to this issue ticket this should have been solved.
[SNAP-1387] Missing pixels after reprojection when using pixel-based geo-coding - JIRA (atlassian.net)
Do you have installed the latest updates?

Hi @marpet,

indeed it’s been quite some time I haven’t updated SNAP, currently running my job again after update!

Thank you a lot!

Update indeed solved my issue, thank you a lot Marco!

1 Like