SAOCOM Terrain Correction error (SNAP 9.0.6)

I am trying to Terrain Correct SAOCOM L1A Merged products, I have an issue because it seems a metadata is missing slant_range_to_first_pixel, is this a known issue with SAOCOM data, or is this a bug?
The matrices computation seems to work fine,
am I making a mistake in the graph did anyone manage to do Terrain Correction on SAOCOM L1A data which could share the graph they used?
Same error appear with ellipsoid corrections.
I am using SNAP 9.0.6

I solved the issue, thanks also to the help of SAOCOM support. The problem is that I was using Topsar merged products, which are not supported in SNAP. I think the main issue as I understood it, is that some info on the timing of the bursts is missing in SAOCOM.
Instead StripMap products are supported, I tried with the StripMap and I managed to make Terrain Correction properly in SNAP, starting from SM L1A products.
In my personal experience I found L1D products to be not perfectly aligned so processing a L1A product and performing Terrain Correction myself worked better for me.