SAR Mosaic - 0% computing raster data after 2 hours

I am trying to mosaic two SAR tiles by using the SNAP tool (Radar --> Geometric --> SAR-Mosaic). The tiles are many but I started with two preprocessed (radiometrically calibrated, speckle filtered using Lee filter and range-doppler terrain corrected) tiles. It has been running for more than 2 hours but the new raster computation process is still at 0%. What am I doing wrong?

Where are the products geographically? Are they close together? Are they at the poles? What projection are you using?
Have you run your pre-processing separate from the mosaic?

Yes, the two products overlap spatially. Geographically the tiles fall in Ghana so they are not close to the poles. I carried out the same set of preprocessing (radiometric calibration --> speckle filtering --> Terrain correction) on both before the mosaic. They are both on WGS84.
Thanks, Iveci.

I’m not sure what it could be then.

Ok, thanks for your support. Could it be due to the memory? My machine runs on 8GB ram; intel i7.

How do you check what projection each product uses?

Hello, have you solved this problem? I also get stuck in it.

Hello everyone,

I have the same error. But I ran a model of land Subsidence in Viet Nam.
I do not see the error message. But still 0% after 4 hours. I use computer Ram: 8G, intel i3.
Help me! Thank you!

you should not create too long graphs, because they are not very memory effective.
Try to split it into two or three parts instead.

1 Like

Thank you very much.
I will try your way.
Good day!

Tan Loi

Dear @ABraun

As this problem was mentioned a lot, so I thought that it is better to not open a new topic for it.

I have two SLC images:

And after using TOPSAR SPLIT (IW3 was selected with 3-5, I mean small area), then I applied below chain in SNAP.

My computer has 16 G RAM which I put 11G for SNAP.

First, it gave me Java heat error but it did not crashed but I restarted my computer and did processing again but it is more than 12 hours that it is 4% raster processing.

I checked task manager but I do not know why SNAP only use 455 Mb while it has many memory available.

So, in my idea, it does not depend how much you have RAM because even with 11G RAM, SNAP cannot use it and do processing but I do not know why!!!???

I was looking at 20 student results for this task. From 20 students, only 5 students did this on their computers. One student has same RAM as me but it took only 20 minutes for her doing this processing but it did not work for me. There were no difference between my laptop and her laptop except mine is HP and her laptop is Levona and new version.

As you process a graph in SNAP, the snappy settings do not matter here.
Please check how to adapt the usable RAM (depends on each computer’s available RAM) here.

Yes. I am doing in in SNAP. I think my SNAP setting is also 11G here.

You can optimize the Processing parameters with a selected Benchmark operator (bottom of this window, e.g. BackGeocoding)

3 Bursts should be doable with 16 GB, but long graphs are often not very memory efficient. I always reommend computing the single steps separately (not as a graph) because it is quicker and you can check if the output looks alright. Especially when you are working with students this helps understanding them better what they do.

Yes I agree with you. Thanks for reply.

Of course, it makes sense to automate the processing when you have to apply it to many products. I don’t know if this is the case for your analysis.
But you will see, applying all these separately will cost you a fraction of the time only.