SAR Range-Doppler Terrain Correction with SRTM DEM: displacement error

Hi all,

I am trying to preprocess a ERS-2 SAR image using SNAP 5.0 but when applying the Range-Doppler Terrain Correction, the area masked as having no elevation seems to be displaced:

I performed the following steps:

  1. Open product: SAR_IMP_1PNESA20061107_110725_00000018A120_00409_60383_0000.E2
  2. Radiometric > Calibrate on the Intensity band
  3. Geometric > Terrain Correction > Range-Doppler Terrain Correction
    DEM: SRTM 3Sec (Auto Download)
    DEM Resampling Method: BILINEAR_INTERPOLATION
    Image Resampling Method: BILINEAR_INTERPOLATION
    Source GR Pixel Spacings: 12.5 x 12.5 (m)
    Pixel spacing (m): 12.5
    Pixel spacing (deg): 1.228941E-4
    Map Projection: WGS84(DD)
    Mask out areas without elevation

The same procedure works fine an a similar image (same track, polarisation, etc.): SAR_IMP_1PNESA20061212_110733_00000018A121_00409_60884_0000.E2

Any help would be appreciated.

Thanks in advance!

Lisa

Try Radar -> Apply Orbit File at first step and see if it makes difference.

Hi junlu,

Thanks for the tip. I read the SNAP Help on the orbit files and from now will always apply this prior to other preprocessing.
Unfortunately, the problem remains…

Would you have any other suggestions?

Many thanks!

If the quality of the orbits is bad you need to use SAR-Simulation terrain correction.

Hi mengdahl,

I tried doing this but it still doesn’t give the awaited result.

I first applied ‘Remova Antenna Pattern’, followed by ‘SAR simulation Terrain Correction’. I tried different values for some of the parameters like the RMS threshold, the WARP polynomial order and whether to ‘Estimate Initial Coarse Offset’. I used the default settings for other parameters. Is there a specific parameter I should pay attention to?

Thanks,

Lisa

Did you use the best available orbits?

I am still new to SAR processing so not yet familiar to all the processing terms and processes, but I dit perform ‘Apply Orbit File’ if that is what you mean.

There are DELFT Precise and PRARE Precise orbits available for ERS-2. Please try both and see if it makes a difference.

I tried the PRARE Precise orbit file before. I now tried the Delft Precise orbit file but got an error message saying these are only available until 2003 for ERS-2, while the image I’m working with originates from 2006.

I was looking for a reference image for a flood image from December 2006 and this image seemed suitable. However, as the problem appears to be more fundamental than I tought, I can look for another one…

Thanks in each case for the assistance!

1 Like

Hi
Try this option when you want to apply range-doppler terrain correction:
Uncheck the “mask out areas with no elevation” checkbox.
I hope your problem will be solved.

Dear all I am experiencing kind of the same problem.

After noise removal, radiometric calibration etc, I perform a terrain correction using the following code:

    def terrain_correction(self):
        parameters = HashMap()
        parameters.put('demName', 'GETASSE30')   # ASTER 1Sec GDEM
        parameters.put('demResamplingMethod', 'BILINEAR_INTERPOLATION')
        parameters.put('imgResamplingMethod', 'BILINEAR_INTERPOLATION')
        parameters.put('pixelSpacingInMeter', self.resolution)
        parameters.put('sourceBands', self.image.getBandNames()[0])
        parameters.put('incidenceAngleForSigma0',
                       'Use incidence angle from Ellipsoid')
        srs = osgeo.osr.SpatialReference()
        srs.ImportFromProj4('+proj=stere +lat_0=-90 +lat_ts=-71 +lon_0=0 +k=1 +x_0=0 +y_0=0 +datum=WGS84 +units=m +no_defs')
        parameters.put('mapProjection', srs.ExportToWkt())
        parameters.put('nodataValueAtSea', False)
        self.image = GPF.createProduct('Terrain-Correction', parameters,
                                       self.image)

I have for example the following S1 acquisition: s1a-iw-grd-hh-20180110t160059-20180110t160124-020094-02241a-001.tiff

If I comment out the mapProjection parameter, the terrain corrected file, matches with the land perfectly well. However there is a catch. It creates a file which is 3 times larger than when defining the output projection.

So by defining the projection as in the example above (I want to define the antarctic polar stereographic which is the epsg 3031), the file is 3 times smaller but is not correctly positioned. Example pic:

Any ideas what I might do wrong here??

1 Like