Segmentation Fault on Fraction of Green Vegetation?

Have you tried moving the data to another location? Could be something with read/write permissions or a complex path (e.g. with accent characters).

Hi @gnwiii , I did the following :

  1. Activated that env which is configured with SNAP.

  2. Opened SNAP from Terminal and run the process.

But still the same error.

Got the following message in terminal, still SNAP was running.

Gtk-Message: 13:23:53.349: Failed to load module “canberra-gtk-module”

Hi @radosuav , I did the following :

Still the error message was same:

Then added 1 extra print in line 14.

But getting the following error:

The SyntaxError is because you cannot have code between the decorator (@click.option()) and function definition (def main()). But from the first run it looks like the crash happens quite early, maybe at import of snappy_utils. Could you try placing print statements on lines 5 and 7.

Hi @radosuav


Data :


Would be very much interested in the issue resolution.

It seems that it is a Linux problem, because on my Windows SNAP it worked.