Segmentation Fault on Fraction of Green Vegetation?

I’m trying to run the Fraction of Green Vegetation Operator, but the it just returns a Segmentation fault with no further explanation. Has anyone managed to get it to work?

The inputs (BIOPHYSICAL/ZENITH) I’m using can be found here:

Is it possible to set a verbose flag or something for these operators to show more info on errors?


I am also facing the same issue. Please let me know if you got any solution for this.

Unfortunately not. I made an effort to try it in several ways, and this plugin never worked. There was always an error or a problem.

@radosuav Can you please explain this?

Sorry but cannot help much here. Segmentation fault is usually related to memory or disk access problems. Have you tried on another machine?

Ok thanks, will try that.

@radosuav did you see @napocornejo’s zenith_angle product, the sun_zenith band is within a sub band sun. My data is also similiar.
Is that fine?

@radosuav Tried with other machine with the following configuration:

  1. SNAP 8.0 Configured with python3.6

  2. SEN-ET 1.0.1

  3. UBUNTU 20.04

  4. RAM-32GB, ROM-256GB

Still getting the same error. What else you will suggest to do?

The location of sun_zenith band looks fine, that’s where it’s located within S2 L2A product and the location is kept when using SNAP subset operator.

I am not sure what could be causing the segmentation fault. Python code used by this operator is fairly simple so I don’t think that this could be the cause. That leaves file I/O for which snappy is used. The plugin was developed and tested with SNAP 7. Maybe something has changed between SNAP 7 and SNAP 8 in the way that snappy should be used. Could you try installing SNAP 7 (you can get it here) to check if that works?

@radosuav sure, I’ll try with SNAP 7 and SEN-ET 1.0.1.

@radosuav Tried with snap 7.0 and SEN-ET 1.0.1 .
SNAP is configured with Python 3.6.13 and compiler used is GCC 9.3.0.
Still getting the segmentation error. What to do now?

Hi @marpet and @ABraun ,
Can you please suggest any solution to overcome this error? I am not even sure if the error is from SEN-ET plugin side or from SNAP side.

I’m afrait we’ll have to wait for someone who is more familiar with this plugin. As this is an external one, we cannot provide support for it. At least I don’t know what caused the error. Are you sure the plugin was installed correctly? For example, did other functionalities of this plugin work before?

Yes @ABraun , I tried it around 4 months ago and was able to run each steps correctly and got the final output.
This time also I’m able to run another function called "leaf reflectance and transmittance estimation.

maybe your input data is different from the last time?

Let’s try to find the place where the segmentation fault occurs. Can you edit in <USEPROFILE>\.snap\auxdata\sen-et-conda-Win64\sen-et-snap-scripts\ and put some print() statements in (e.g. on lines 15, 21, 39, 42).

1 Like

Ubuntu 20.04 provides Python-3.8, so it is important to tell us which Python-3.6 you are using (Anaconda, deadsnakes ppa, or ??).

Hi @gnwiii I created a conda environment with python 3.6 and then configured with SNAP. Then check the python configuration which is running perfectly.

Yes @ABraun The data location is different but same Sentinel 2 L2A data is used.

You could get a segmentation fault in a python import library (due to different compiler runtime libraries) if the conda environment is not active.