Sen2Cor-02.05.05-win64 -- Product metadata file cannot be read


#1

Hello,

It seems that the Sen2Cor-02.05.05-win64 cannot read the metadata file using the old naming conventions (S2A_OPER_MTD_SAFL1C_PDMC_20160929T231412_R070_V20160929T184812_20160929T184813.xml). The error I receive is: Product metadata file cannot be read. It works on files with the newer naming convention (MTD_MSIL1C.xml).
Is there any way to work around this or is there an error I have possibly made?

Thanks,

Addy


#2

Hello,

exactly I have the same problem. I refers to older scenes. I have downloaded many s2 Level1c products from year 2015 which I have to convert to surface reflectance in order to obtain biophysical parameters such as LAI, FAPAR…I tried to open the scene in SNAP 6.0 but it seems that SNAP as standalone application has problem with older metadata format and sen2cor is not an exception:

Newer sentinel 2 scenes work without problem (all downloaded this year). I tried sen2cor directly from commandline as well as integrated in SNAP.


#3

Hello,

could you ever solve this? I have the same problem.


#4

Hi @Iricek,

SNAP should open the old products, please, could you tell me the name of one of the problematic products to download it, reproduce the error and try to fix the bug?

Thank you!


#5

One of mine is: S2A_OPER_PRD_MSIL1C_PDMC_20151224T192928_R065_V20151224T103329_20151224T103329.SAFE. I hope that helps.


#6

Hi,

that product is opening properly on my PC. Are you working with the last version of SNAP? There is an old issue with the old products that was produced by the long path on Windows. Could you try to copy your products to a shorter path (for example C:/tmp)?