Sen2cor 10 m resolution processing error

Hi everyone

Could someone kindly assist me. I have been experiencing this error with pre-processing S2A data for the past week and I have tried with different computesr and have also tried reinstalling everything but it still gives me this error:

Progress[%]: 0.12 : PID-764, No scene classification processing for 10 m resolution in sc_only mode, elapsed time[s]: 2.844
Syntax error in metadata, see report file for details.
Parsing error:
Schema file: S2-PDGS-TAS-DI-PSD-V13.1_Schema\S2_User_Product_Level-2A_Metadata.xsd
Details: Element ‘L2A_Product_Organisation’: Missing child element(s). Expected is ( Granule_List ). (line 0)

Someone please help

Thank you



please see:

@lveci @marpet
Maybe one reason why this is reported so often is the little window that appears after every error in SNAP at the right bottom which directly leads to this forum. Maybe some of the errors could rather be treated as warning messages instead, for example the manual abortion of processes.

Good idea, but maybe hard to implement. SNAP (actually the underlying NetBeans platform) scans the log output for certain keywords and then pops up the balloon message .

Without looking into the details, I think it should be handled in Sen2Cor.
The problem should not be logged in this way but handled within sen2cor gracefully, with a nice explanation for the user.

that would make sense in this case, yes.