Sen2Cor 2.11.00 not working

Hi! I hope y’all are doing well. I’ve been trying to apply atmospheric corrections to some S2A_L1C images in SNAP and Python (miniconda prompt 3), but when running the plugin in SNAP it stops the process and says that it can’t find the metadata file, but it is actually there, I tried to use multiple versions but they didn’t work. I also tried running Sen2cor with the command line, and it worked if I call L2A_Process.bat + the product path, but I am not really sure if this is the best way, because I want to set specific parameters recommended by my professor who is Msc in Remote sensing, I dont know how to write a code specifying that the ozone content is f-250 and, Aerosol type RURAL and Mid latitude SUMMER.
I would really appreciate if any of y’all can help me with this problem.

Hi @GeoJose

Here’s the Software User Manual for 2.11. Section describes User configuration (via the L2A.GIPP.xml file from Sen2Cor-02.11.00-win64\Lib\site-packages\sen2cor\cfg\L2A_GIPP.xml)



Thank you for answering.
I read the whole manual in order to better understand the tool. I tried to run it in different ways and find out that my directory was too long. Now it runs the image and creates a new peoduct L2A (wich seems better than the L1C have different pixel values even). But when it is almost done it gives out an error, do you know if it’s ok to use the product as I got it?:

‘NoneType’ object has no attribute ‘error’
Traceback (most recent call last):
File “C:\Users\User.snap\auxdata\Sen2Cor-02.11.00-win64\Lib\site-packages\sen2cor\”, line 696, in main
if not postprocess(config):
File “C:\Users\User.snap\auxdata\Sen2Cor-02.11.00-win64\Lib\site-packages\sen2cor\”, line 448, in postprocess
config.logger.error('cannot copy report file: s' fnLogIn)
AttributeError: ‘NoneType’ object has no attribute ‘error’
Progress[%]: 100.00 : Application terminated with at least one error.
Finished tool execution in 2170 seconds

It looks like it tried to copy a report file and couldn’t (maybe it’s open somewhere and the file is locked?). I would suspect that the product that has been created is fine since the logging would be just to tidy up at the end, but I’m not sure.

1 Like