Sen2Cor 2.2.1 error "Permission denied"


After following the installation instructions, in the video, and despite the conda and L2A_Process --help commands executing without error. The tool will not run when trying to process an image. The same error is encountered in the command window and through SNAP:

I have tried using the default folder name, a shorter folder name, putting the file in D:, putting the file in a sub-folder on C:, but always the same error comes up.

Any ideas would be greatly appreciated!


Quick update - after starting over reinstalling everything and making sure everything is set according the posts on the forum here, there is a new error, as before it is the same error in SNAP and cmd line:

try to close SNAP, delete the temporary output files and run it again.

thank you for the suggestion, but unfortunately it does not fix the problem. The same error comes when it is executed even if I delete the temporary output files. I tried downloading a different image, thinking that might be the problem, but not the same error comes up even if I use a different image.

as suggested in the other topic maybe there is something wrong with pytables.
Do you have other python installations on your pc?
Have a look if pytables is in C:\Anaconda2\Lib\site-packages\ (if this was your Anaconda installation path)

Is it listed when you type pip list in your command line?
I would try pip uninstall pytables and then pip install pytables.

thanks, so I just uninstalled tables and reinstalled, it’s on version 3.3.0

But still the same error comes up when I try to run either in command line or through snap

This is a screenshot from the uninstall and then installation process

try this:
pip install pytables== --force-reinstall

Edit: it cannot be found. I can’t locate any previous versions by now…

You can try uninstalling it with pip and install a custom version from here:

The --force-reinstall is working, now on to a new error

I will try installing version 3.2 from the link you provided.

Following a clean installation of Anaconda, Sen2Cor and SNAP I’ve come across the same problems. The problem is the same on two separate machines, both running Win7. In the meantime I’ve found that the command line version of Sen2Cor works great on Mac OSX 10.11.6 so that will be the temporary fix while the windows version is sorted out.

Thank you very much for your help, it has helped us certainly move forward and better understand the issues.

I still think this ist caused by other python versions floating around on the PC and the path variables are not set in the right order. But this is only a guess.
I had similar problems installing it the first time because I run a separate version of Python, one for QGIS and one for ArcMap ect… It hast to be made sure that the install sen2cor uses the Anaconda2 version of python.

First answer is crucial: