Sen2cor 2.3.0 error xml metadata


I (seemingly) installed Anaconda and Sen2cor 2.3.0 on a Windows machine without any problems, but when I try to process a product or granule, I run into the following error:

C:>L2A_Process C:\S2A_OPER_PRD_MSIL1C_PDMC_20161008T183126_R051_V20161008T105022_20161008T105022.SAFE
Traceback (most recent call last):
File “C:\Program Files\Anaconda2\Scripts\”, line 11, in
load_entry_point(‘sen2cor==2.3.0’, ‘console_scripts’, ‘L2A_Process’)()
File “C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\”, line 169, in main
File “C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\”, line 3072, in setSchemes
self.logger.fatal('wrong identifier for xml structure: ’ + product)
AttributeError: ‘NoneType’ object has no attribute ‘fatal’

Can someone help me identify the exact problem?

Many thanks!


Try to delete any L2A directory (related to this particular L1C product) already created in your working directory and try to run L2A_Process again.


The problem is that sen2cor looks for config and other data in the root of the sen2cor package, in a subdirectory called cfg… actually that folder is inside another directory called sen2cor in the package, so you have to copy-paste it. In your case:

The package is installed in the folder:

"C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\

In that directory there should be another directory named cfg (with all config data and other things), but there is not…

As a matter of fact, that directory is in this other folder:

"C:\Program Files\Anaconda2\lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\

so, you just have to copy the whole “cfg” folder (with all its contents) from this last path to the first one.

Hope it helps. It worked for me.


but i have a new error: WindowsError: exception: access violation writing 0x0000000000000024. Do you know how to slove this?

1 Like

i haven’t stepped into that problem. Have you tried opening the cmd window as administrator?

After a fresh install of Sen2Cor on Windows, you need to close your cmd window and open a new one so that all the environment variables are correctly set.

Best regards,