Sen2Cor 2.3.0 installation problem: no L2A_Process script existing

The installation procedure of Sen2Cor 2.3.0 does not generate the L2A_Process script (tested on two 64bit machines: Fedora and Linux Mint). I did on both a complete reinstall and had Sen2Cor 2.2.1 running there.

The previous 2.2.1 version came with these scripts:

[server@localhost ~]$ ls -la ~/anaconda2/bin/L*
-rwxrwxr-x. 1 server server 410 Nov 27 02:21 /home/server/anaconda2/bin/L2A_Process
-rwxrwxr-x. 1 server server 428 Nov 27 02:21 /home/server/anaconda2/bin/L2A_Process-02.02.01
-rwxrwxr-x. 1 server server 422 Nov 27 02:21 /home/server/anaconda2/bin/L2A_Process-2.2.1

while there are not created during the Sen2Cor 2.3.0 install procedure (also not elsewhere, I searched on the entire machine).

Here the procedure log:

creating dist
creating 'dist/sen2cor-2.3.0-py2.7.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing sen2cor-2.3.0-py2.7.egg
creating /home/mneteler/anaconda2/lib/python2.7/site-packages/sen2cor-2.3.0-py2.7.egg
Extracting sen2cor-2.3.0-py2.7.egg to /home/mneteler/anaconda2/lib/python2.7/site-packages
Adding sen2cor 2.3.0 to easy-install.pth file
Installed /home/mneteler/anaconda2/lib/python2.7/site-packages/sen2cor-2.3.0-py2.7.egg
Processing dependencies for sen2cor==2.3.0
Finished processing dependencies for sen2cor==2.3.0
Copying OpenJPEG library to /home/mneteler/anaconda2/lib/ ...
Copying atmospheric library to /home/mneteler/anaconda2/lib/python2.7/site-packages/sen2cor-2.3.0-py2.7.egg/sen2cor/ ...
SEN2COR 2.3.0 setup script:
This will finish the configuration of the environment settings.
OK to continue? [y/n]: 
Please input a path for the sen2cor home directory:
default is: /home/mneteler/sen2cor
Is this OK? [y/n]: creating /home/mneteler/sen2cor
creating /home/mneteler/sen2cor/cfg
Setting environment for sen2cor ...
Creating L2A_Bashrc script under:
Creating L2A_Process.bash script under:
Creating the configuration file for OpenJPEG2 under:
creating /home/mneteler/.config/glymur
Congratulations, you are nearly done ...
Last step: cd to /home/mneteler/sen2cor,
source the <L2A_Bashrc> script either manually via: "source L2A_Bashrc"
or integrate this call in your .bashrc or .profile script. Afterwards,
- you can call the processor from everywhere via: "L2A_Process"
- you will find the default configuration called "L2A_GIPP.xml" under:
Installation sucessfully performed.

mneteler@server2 ~ $ source ${SEN2COR_HOME}/L2A_Bashrc
mneteler@server2 ~ $ L2A_Process
L2A_Process: command not found
mneteler@server2 ~ $ ls -la ~/anaconda2/bin/ | grep L2A

I tried with both Anaconda2-4.0.0 and Anaconda2-4.2.0 including a complete removal and reinstallation.

Any idea what’s wrong here? Thanks.

I also have this problem - on windows no …\Scripts\L2A_Process.exe generated

I also have the same problem, on Ubuntu Desktop 16.04.

L2A_Process script is not generated. Installation finishes without any error.


I have also this problem. L2A_Process is not recognized. See screenshot

I tried to update glymur to version 8.7.0 because during installation I got an error but still doesn’t works.
Sometimes I think that older versions are better than new :confused:

Best Regards

@kiryl23: Is L2A_process in your folder, for example C:\Anaconda2\scripts?

If yes, you should add this folder to your path variable to be able to run the program from any location.

ABraun thaks for your answer. It’s very interesting but i can’t find L2A_process.exe and any .py files. How its possible?


in this something went wrong with the installation.

What happens when you type “python” in your command shell? Is this the version you installed with Anaconda?

Same issue here. I’m using Windows 7.

Cannot find L2A_process script.

Although sen2cor via SNAP seems to be running fine.

Can you check if the following command works on your Windows systems?

python C:\Anaconda2\Lib\site-packages\sen2cor-2.3.0-py2.7.egg\sen2cor\ --help

You can try the same type of command adapting it for your installation configuration on a Linux system.


Hi Jerome

So in my Ubuntu 16.04 machine the following command works:

python /home/pareeth/anaconda2/lib/python2.7/site-packages/sen2cor-2.3.0-py2.7.egg/sen2cor/ --help
usage: [-h] [–resolution {10,20,60}] [–sc_only] [–cr_only]
[–refresh] [–GIP_L2A GIP_L2A]

Sentinel-2 Level 2A Prototype Processor (Sen2Cor). Version: 2.3.0, created:
2016.11.18, supporting Level-1C product version: 14.

Even the L2A process seems to be working (currently running). So i guess the installation some how skips building the L2A_process scripts in the bin directory.


I have this on my computer.

But executable file is not in this directory.

Thanks for your reply Sajid. Indeed there seems to be an issue in the final steps of the installation. The SW team is currently investigating the origin of this issue.

Best regards,

I can confirm that L2A_Process works only if the path is entirely explicited in the command line

@spareeth @Jerome The workaround also confirmed on Fedora:

export PATH=$HOME/anaconda2/bin:$PATH
export SEN2COR_HOME=$HOME/sen2cor
source ${SEN2COR_HOME}/L2A_Bashrc

python $HOME/anaconda2/lib/python2.7/site-packages/sen2cor-2.3.0-py2.7.egg/sen2cor/ --help 
usage: [-h] [--resolution {10,20,60}] [--sc_only] [--cr_only]
                      [--refresh] [--GIP_L2A GIP_L2A]
                      [--GIP_L2A_SC GIP_L2A_SC] [--GIP_L2A_AC GIP_L2A_AC]

Sentinel-2 Level 2A Prototype Processor (Sen2Cor). Version: 2.3.0, created:
2016.11.18, supporting Level-1C product version: 14.

Awaiting the next release I’ll write a small helper script to make the processor visible to our existing Sentinel-2 processing chain.

Thanks for the community effort to figure this one out :slight_smile:


I had the same issue (on Ubuntu). The problem was that somehow the setuptools were broken in anaconda.

So what I did was (note that the first step throws an error, but that’s ok):

pip uninstall setuptools
pip uninstall sen2cor
pip install setuptools
python install

like that the /bin files are created as they should be.

You will see this in the install log when it says
Installing L2A_Process-2.3.0 script to /opt/anaconda2/bin
Installing L2A_Process-02.03.00 script to /opt/anaconda2/bin
Installing L2A_Process script to /opt/anaconda2/bin

as long as setuptools are broken this output will be missing.


@bleutner Magic!

Your procedure helped (I had to run the two uninstall procedures several times to get rid of all versions present on my machine).


I confirm, exactly these are my results from today. We will update the setup script tomorrow to fix that issue.

The workaround Benjamin proposes does work, thanks for that, however the root cause is in fact a wrong entry located in the With that corrected, also the original setuptools from anaconda will work.
I attach the corrected here: (397 Bytes). The workaround is as follows:

  1. replace the located in parallel to the installation script with the attached one.
  2. repeat python install,
    After that the scripts should be present.
    It passed our tests as we had the more recent setuptools already installed so we did not notify the bug, sorry for that. We will place an updated version of the sen2cor installation asap.
1 Like

I approve Benjamin method. It works and also separately bands have a georeferention after Sen2Cor.

Hi all,

The corrected Sen2Cor v2.3.0 packages have now been updated (since 29/11/2016 at 15h00 CET time) on the website:

As the note on the website says, “Please note that the software packages have been updated on
29/11/2016 at 15h00 CET time due to a mistake in the packaging process. If you downloaded them before the indicated date, please re-download them.”

Sorry again for the inconvenience this may have caused.

Best regards,