Sen2cor 2.3.1 processing error

Thank you Abraun,
I will try

I tried and do steps as guide but the problem could not be solved. I am so boring now:confused:

Dear ABraun,
I check the system and event log file. There is a conflict between 2 manifest files. This is the event log file
Log Name: Application
Source: SideBySide
Date: 6/29/2017 6:29:48 PM
Event ID: 80
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: TranBaoTran-PC
Activation context generation failed for “C:\Anaconda\Library\bin\hdf.dll”.Error in manifest or policy file “” online. A component version required by the application conflicts with another component version already active. Conflicting components are: Component 1: C:\Windows\WinSxS\manifests\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.4940_none_08e4299fa83d7e3c.manifest. Component 2: C:\Anaconda\Library\bin\Microsoft.VC90.CRT.MANIFEST.

I don’t know what to do now. You have any suggestions to tell me ?
Thank you very much

I have absolutely no idea, sorry :confused:

I have been trying to use the Sen2Cor but unfortunately without success, when I ask for the atmospheric correction I received this error: TypeError: ‘float’ object cannot be interpreted as an index”. I read over this forum that the solution for this is to change the numpy version, specifically the user Leonhalt3141 suggest downgrade to numpy 1.11.3. I really appreciate if someone can tell me the steps for doing this, I mean, how and where I should change the numpy version? Thank you very much!

open your command window and type the two commands given here:

Dear Andreas Braun
Thank you very much for your support! Now it works! :slight_smile:

Good to hear. :slight_smile:

I downgraded to numpy 1.11.3 but now get the error: ImportError: numpy.core.multiarray failed to import

since this error comes sooner now than the float index error, i expect that numpy 1.11.3 does not include the numpy.core.multiarray but noone else seems to have this problem. any known solutions?

the multi-array functionality is featured in numpy quite a long time so I doubt that it is a version issue.
Do you have other python installations on your PC?

This is built in a conda environment for python 2.7. i also have python 3.6 installed on the computer. if i check the version of numpy with:

python -c “import numpy;print numpy.version;print numpy.file”;

it does say that it is version 1.11.3

but which python is addressed by the command?

what is displayed if you simply enter python?

python 2.7.13 with conda 4.3.17

alright, so numpy is at least installed in the correct environment.

You can uninstall numpy again and download the wheel-file from here instead:
(make sure it matches the anaconda version)

Then type pip install wheelfile.whl

unfortunately the error remains. I am not sure what you mean with the right anaconda version? The website only shows different packages for different python versions and not anaconda versions. Since i run python 64 bit, version 2.7 i downloaded: numpy‑1.11.3+mkl‑cp27‑cp27m‑win_amd64.whl but the multiarray error persists after this installation. i checked the version again in python and it is installed correctly at 1.11.3.

yes, cp27m-win_amd64 is the correct one. Strange that it still persists…

Have you tried directly installing numpy in the 27 version?
pip install --target c:\python-2.7\Lib\site-packages numpy
(or wherever your Python is installed)

okay i found the solution:

uninstall matplotlib and scipy, download them from the same site as you adviced for numpy ( and install those.

now it works?

yes. the other error was related to the fact that i already had a half-processed .SAFE file and i didn’t want to get off-topic

I met the same issue. Did you solve this problem and process the data successfully?