Sen2Cor 2.4.0, Anaconda based Version, Recent Issues


#1

In the course of the Sen2Cor 2.4.0 upgrade we have developed a series of stand-alone installers which are described under:

Sen2Cor 2.4.0, Stand-Alone Installers, How To Install

We strongly recommend testing these simplified installation first, as it will prominently reduce the installation overhead and problems in contrast to a full Anaconda installation.

Only in case if you are unsuccessful in installing the software via the stand-alone installers or if you have special needs to prefer the classic Anaconda installation, continue with the installation steps as described in detail in section 4.2 of the release note: S2-PDGS-MPC-L2A-SRN-V2.4.0.pdf, available at the ESA STEP Website:

http://step.esa.int/main/third-party-plugins-2/sen2cor

At date of this release, the three following new problems are identified which can occur after installation using the Anaconda environment:

  1. There is a bug in the libxml2 library version 2.9.4 installed by Anaconda 2.4.0 which is used in the SEN2COR’s L2A_XmlParser.py module for reading and validating XML config files L2A_CAL_AC_GIPP.xml, L2A_CAL_SC_GIPP.xml and L2A_GIPP.xml. Even though the XML files itself are correct, they are not correctly validated as such by the XML parser due to this bug. Details on this problem are described here:

https://bugzilla.gnome.org/show_bug.cgi?id=766834

The solution is, to downgrade the libxml2 library to the version 2.9.2 which is not affected by the bug. This is done by the following command:

“conda install libxml2=2.9.2”.

  1. The recent version of Anaconda 4.40 installs by default numpy version 1.12. Starting with this version, the deprecated ability to use float indices has finally been removed. However, the atmospheric correction module, which is a library, uses this feature extensively so that a downgrade to numpy 1.11 is currently essential, until the atmospheric correction module has been adapted to this new interface. Therefore, the Sen2Cor installer will automatically downgrade numpy to version 1.11. Details on this issue are described here:
  1. During performance test it has been observed, that the recent openjpeg2 libraries as installed and maintained by the Glymur packager show a slowdown in decoding the JPEG 2000 image by a factor of two. This issue is fixed for the standalone installers by recompiling the openjpeg2 libraries. We provide the recompiled openjpeg2 libraries which are used in the standalone installers also for download at the following location:

http://step.esa.int/main/third-party-plugins-2/sen2cor

Users that want to make use of the better performance are advised to replace the existing openjpeg2 lib (named as libopenjp2.so.2.1.2 (for Linux, marked as yellow) with the ones provided. Example for Linux:

$anaconda/lib> ls -l libopenjp2*
19 Aug 28 11:47 libopenjp2.so -> libopenjp2.so.2.1.2
288328 Aug 28 10:12 libopenjp2.so.2.1.2
19 Aug 28 11:47 libopenjp2.so.7 -> libopenjp2.so.2.1.2

The macOS version is labeled: libopenjp2.2.1.2.dylib located under anaconda/lib
The windows version is labeled: openjp2.dll, located in the Anaconda2\Library folder.

As the versions for the original libraries and the replacement are identical, the links to the final library should point to the correct versions. If not you have to adapt the link names as well.

Please note that the stand-alone installers described under :

Sen2Cor 2.4.0, Stand-Alone Installers, How To Install

are not affected by all the issues listed above.

If it turns out that the stand-alone installers described above work sufficient, the provision of the Anaconda Runtime Versions will be discarded in upcoming releases.

If you observe any further issues during installation of Sen2Cor under Anaconda, please reply here, under this thread, with an explicit information on which operating system the issue occurred. We will then try to provide recommendations. Please, do not open a new thread for this purpose, as it will be difficult for us to track the problems, if multiple threads with the same issues exist.

with best regards,
Sen2Cor Development Team


#2

see also:


#3

The standalone file with .run extension just opens in web browser if I click it - I was trying to test it for ubuntu. How is it supposed to work? I have no experience installing anything from a .run file.

ok it is explained here Sen2Cor 2.4.0, Stand-Alone Installers, How To Install
it is confusing that the file is not compressed.


#4

Hi all !
I tried to install sen2cor 2.4.0 (stand alone) . So i wrote L2A_Process and the error was: too few arguments.
Have you any idea what should i do?

Thanks in advance
R.


#5

the same was asked and answered here:


#6

Do you think that happens because i have windows 7 64bit?

also, i run the standalone and two few arguments again!


#7

that is not related to the operating system. You simply type python setup.py install in one line.

But, according to the manual, installing the script is no longer required. You can directly use L2A_process.py