Sen2Cor 2.4.0, Stand-Alone Installers, How To Install

Hi

I am using Windows10 and having terrible trouble installing sen2cor I keep getting a python issue when I follow the instructions above and when I try and use it in SNAP I get a whole host of errors.I include some snaps below to show what I have had trouble with - any ideas greatly welcomed!

thanks


you forgot writing ‘–help’ after ‘L2A_Process.bat’, and there will be a space between them.

After working on other things for some days, installing windows updates, another python version and a few other things L2A_Process.bat seems to work now. It shows me the commands to use, one of them is -h. I don’t know what solved the problem.

I don’t know what happened when I was using ‘sen2cor’, but the problem makes me crazy, I can’t solve it, please give me a hand.

What version of SNAP are you using? And what version of sen2cor? Are you using the standalone installer or you have installed Anaconda?

The version of SNAP is 5.0, and sen2cor is 2.4.0-win, I am sure that I am using the standalone installer, but I have not installed Anaconda, should I install it?

No, if you are using the standalone installer Anaconda is not needed. But this standalone installer is not compatible with version 5.0 of SNAP, so you have to wait to version 6.0 release to be able to use your sen2cor from SNAP. Meanwhile, you should be able to run it from the command line. Have you tried it?

I have run sen2cor from the command line successfully, I will download version 6.0, thanks for your help.

You have to wait for the official release, in the beta version the sen2cor plugin is not available.

Oh, this is a bad news, OK, I will wait for it, thank you again.

Can you edit L2A_Process.bat and add “-s” when calling python /path/to/L2A_Process.py ?

I have a problem. I downloaded the standalone installer Sen2Cor-2.4.0-win64. The installation was successful. After calling the command “L2A_Process.bat -help”, there were no errors. I read the granules and the program began to process the data. The process was very slow. I left the processing all night, but it was still processing in the morning. In addition, I noticed that the process didn’t want to end because it started repeating itself. The data were processed in more than 99%, then it dropped to 97%, then it increased to about 99% and so on over and over. I had to stop the process. There were no errors in the console. It seems to me that program couldn’t pass the final processing stage. In addition, one granule in an anaconda is processed on another computer for about 15 minutes, but here it lasts all day and hasn’t ended. I also noticed that a folder with L2A data was created, but missing jp2 files.
I have not installed anaconda on my computer, but I have GDAL. I also tried changing the environment variables, but nothing changed.
Sen2Core Path C:\Sen2Cor-2.4.0-win64\Sen2Cor-2.4.0-win64
Sen2Core Bin  C:\Sen2Cor-2.4.0-win64\Sen2Cor-2.4.0-win64\bin
Sen2Core Home C:\Users\xxx\documents\sen2cor

1 Like

Hi Uwe,

Do you know some approximate date of sen2cor 2.5.0 release?

Thanks,
Mak

Hello,
I am new to Sen2cor. However, I could install the standalone installer successfully, but I have the problem with integration of sen2cor with SNAP. When I open the sen2cor editor, all parameters field are empty! Can anyone help me how to integrate sen2cor standalone with SNAP, please?

Hi Pym,

there is a youtube tutorial (for Win8 and Win10), which shows how to integrate sen2cor in SNAP:


However in my opinion it is easier to use the standalone version.

Best regards
Sebastian

Hi everybody,

I believe that I found a bug in sen2cor: it cannot handle blanks in the file path.
I put my standalone sen2cor in a folder with blanks and was not able to show the help with “L2A_Process.bat –help”.
I then copied it to a file location without blanks where it worked just fine.

  • Sebastian

Hi Sebastian
Thank you very much for your reply. However, I believe the issue is compatibility of Sen2cor 2.4 with SNAP 5. so you cannot integrate sen2cor in SNAP 5. I think it works with SNAP 6.
By the way, I tried to Run sen2cor standalone in CMD itself and ran the atmospheric correction smoothly.
Thank you very much.

regards,

Hello,

Thank you for the tutorial. It works fine.
However, is it possible to process all the files (images) of a folder in one step ?
For example, I have 30 Sentinel-2 images TOA and I want to transform them in BOA using Sen2Cor. I could do it manually file by file, but it’s very inconvenient. I already tried “L2A_Process D:\myfolder\ .SAFE" or
"L2A_Process D:\myfolder\ .
.SAFE” but it didnt work . It must be easy but I’m not used to cmd commands.
Can someone tell me how to do a loop or a bach ? Thank you.

Regards,
GeckoTokay

hello, I read this somewhere in this forum and adapted it to use in the command line in Linux : sudo bash -c 'for scene in Level1C -1 /D/data/Level1C/S2_MSIL1C;do echo “Doing scene:$scene”;L2A_Process $scene --resolution=10;done’** . Please note that Level1C is the folder containing level 1C (unzipped) images. The products from Sen2cor are placed in the same working directory. Hope this helps. Also have a look at Batch processing and other similar posts on the forum.

This is a link from ESA, is not THAT helpfull for those not familiarized with programming lenguage though:

But gets you on the right direction :slight_smile:

Nevertheless i could not make it through the running errors, hope this will works for you