Sen2Cor 2.5.5 Error

Dear All, I have managed successfully the Sen2Cor 2.4.0 version. Now, after installing the new version (Sen2Cor 2.5.5) the data processing of Sentinel-2 I had problem, as you can see in the screenshot:

The message in red says: UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xf1 in position 66: ordinal not in range(128)

I think that is a problem with the file :

I need help. Maybe someone has a solution. I plan to return to version 2.4.0, but I lost the installation file. Please, can someone give me a copy of the

Thank in advance.

Hi @dfran,

do you have any ‘strange’ character in the path of your input image? Have you tried sen2cor v2.5.5 with an image that worked with v2.4.0?
In any case, the link for the 2.4.0 version is but I think that downgrading the version will not fix this problem.

Dear @obarrilero,
Thank you very much for your answer and file attached. I installed but it has failed because the pluging change from 6.0.0 to 6.0.2 version. I have reinstalled snap 6.0 again and then, I have installed again from remote and local bundled option from snap 6.0.

Now, I have another error message, as you can see in the screenshot:

The message in red says: AttributeError: ‘bool’ object has no attribute ‘ARCHIVING_TIME’

Could you help me again?. Please, any suggestions on what I should do to be able to use the tool Sen2Cor for atmospheric correction of sentinel-2 images.

Best regard.

Hi @dfran,

I have the same problem, but I’m using the Windows Command L2A_Process.
And do you have any solutions?

Here’s the error, the same with yours:



Hi @obarrilero,

I have the same question about this error. If you have any idea please reply here.

I‘m appreciate your feeds.

Thank you.

I had this error:

this is no error, you have to add some parameters for sen2cor to start working. It is explained here: Sen2Cor-02.05.05-win64 - AttributeError: 'L2A_Tables' Object has no attribute '_L2A_Tile_PVI_File'