Sen2cor 2.5.5: L2A tables error

Dear all,
It seems sen2cor doesn’t work properly when the resolution is set to 10 m. It raises the following error:

AttributeError: ‘L2A_Tables’ object has no attribute ‘_L2A_Tile_PVI_File’

On the other hand the process runs correctly when I set 20 m as resolution. Do you encounter the same problem?

Thank you

1 Like

Yes. Issue has been raised several times. No reply so far :frowning:

1 Like

Hi! Having the same problem here. Still no reply? Any other way to convert TOA to Surface Reflectance for 10 m resolution?

Please, see:

Hi obarrilero
Thank you for your reply!
Unfortunately, I am still having the same problem. After running the line as you suggested:

C:\Users\MyUser\MyPath>L2A_Process.bat C:\Users\MyUser\MyPath\S2A_MSIL1C_20170619T184921_N0205_R113_T10SEG_20170619T185728.SAFE

The process gets stuck in the same error. Everything goes smoothly until 7.94% and then it just stays there and I have to exit the process manually.

Operation mode PDGS is not supported for Product version 14.2.
Operation mode will be reset to TOOLBOX.

Sentinel-2 Level 2A Processor (Sen2Cor). Version: 2.5.5, created: 2018.03.19, supporting Level-1C product version <= 14.5 started …
Product version: 14.2. Operation mode: TOOLBOX. Processing baseline: 02.05.
No resolution specified, will process all resolutions.
Progress[%]: 0.03 : PID-9532, L2A_ProcessTile: processing with resolution 60 m, elapsed time[s]: 0.848, total: 12 days, 0:10:11.767000
Progress[%]: 0.03 : PID-9532, L2A_ProcessTile: start of pre processing, elapsed time[s]: 0.004, total: 12 days, 0:10:11.771000
Progress[%]: 0.04 : PID-9532, L2A_Tables: start import, elapsed time[s]: 0.265, total: 12 days, 0:10:12.036000
Progress[%]: 0.09 : PID-9532, L2A_Tables: band B01 imported, elapsed time[s]: 1.071, total: 12 days, 0:10:13.107000


Progress[%]: 7.91 : PID-9532, L2A_Tables: band CLD exported, elapsed time[s]: 0.437, total: 12 days, 0:13:32.702000
Progress[%]: 7.92 : PID-9532, L2A_Tables: band AOT exported, elapsed time[s]: 0.141, total: 12 days, 0:13:32.843000
Progress[%]: 7.94 : PID-9532, L2A_Tables: band WVP exported, elapsed time[s]: 0.594, total: 12 days, 0:13:33.437000
Process L2A_ProcessTile-1:
Traceback (most recent call last):
File “C:\Users\MyUser\MyPath\lib\multiprocessing\”, line 258, in _bootstrap
File “C:\Users\MyUser\MyPath\Lib\site-packages\sen2cor\”, line 122, in run
if not self.process_60():
File “C:\Users\MyUser\MyPath\Lib\site-packages\sen2cor\”, line 148, in process_60
return self.process()
File “C:\Users\MyUser\MyPath\Lib\site-packages\sen2cor\”, line 229, in process
if self.postprocess() == False:
File “C:\Users\MyUser\MyPath\Lib\site-packages\sen2cor\”, line 311, in postprocess
if not self.tables.exportBandList():
File “C:\Users\MyUser\MyPath\Lib\site-packages\sen2cor\”, line 2307, in exportBandList
fn = os.path.basename(self._L2A_Tile_PVI_File)
AttributeError: ‘L2A_Tables’ object has no attribute ‘_L2A_Tile_PVI_File’

Any idea what might be happening?
Thanks in advance

Hi all,
In case you run into the same problem. It worked for me running it for resolutions 60, 20, 10 (in that order). See answer by @jmendrok in this post.