Sen2cor 2.5.5 manifest error

I had the problem below when I run Sen2cor 2.5.5 on S2A_OPER_PRD_MSIL1C_PDMC_20170121T191416_R108_V20150829T103026_20150829T103026.SAFE:

Traceback (most recent call last):
File “C:\Sen2Cor-win64\lib\multiprocessing\”, line 258, in _bootstrap
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 136, in run
if not self.process_10():
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 179, in process_10
if not self.process_20():
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 158, in process_20
return self.process()
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 229, in process
if self.postprocess() == False:
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 324, in postprocess
mn.generate(self.config._L2A_UP_DIR, self.config.L2A_MANIFEST_SAFE)
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 353, in generate
self.addDataObject(dataObjectSection, filepath, ids[filepath], l2productpath)
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 225, in addDataObject
byteStream.attrib[“mimeType”] = self.getMimeType(href)
File “C:\Sen2Cor-win64\Lib\site-packages\sen2cor\”, line 201, in getMimeType
return dicoMimeType[href.split(".")[-1]]
KeyError: ‘04\QI_DATA\S2A_OPER_MSI_L1C_TL_EPA__20161007T141124_A000963_T32UND_FORMAT_CORRECTNESS_report’

I looked into the ‘’ script and realized the error is coming from the ‘getMimeType’ function because the dictionary there does not contain that key. The key is supposed to be one of ‘xml’, ‘gml’, ‘html’, ‘xsl’, or ‘jp2’.

Has anyone encountered this issue and how was it solved?

Thanks a lot in advance!