Sen2cor 2.8 fails on product from early 2016 - 'bool' object has no attribute 'SPACECRAFT_NAME'

In my case, I still encountered an error:

Product version: 14.2. Operation mode: TOOLBOX. Processing baseline: 02.01.
[CRITICAL]  L2A_Config: 3181   Error in creating L2A User Product
[CRITICAL]  L2A_Config: 3181   Error in creating L2A User Product

Nice to hear that it works for some people, though

New version sen2cor 2.9.0 solved the problem. See also item New REFINED L1C tiles do not process with Sen2Cor 2.8

3 Likes

Thanks for your suggestion @vicencpala. The new sen2cor 2.9.0 worked better. I was able to get to a later step of the processing. However, when I tried implementing terrain correction, an error occurred. I posted this issue here. Basically a file (srtm data) access conflict was indicated by the error message. If you know a possible troubleshooting tips, please let me know.

For me 2.9 doesn’t work with new images, same problem… AttributeError: ‘bool’ object has no attribute ‘SPACECRAFT_NAME’

What about 2.10?
You can find it here: Sen2Cor 2.10

oh 2.10 works :slight_smile:

1 Like