Sen2cor artefacts


When I process a multi-granule product sen2cor leaves very distinct artefacts along the granule borders. I understand that this is because of processing each granule with different atmospheric parameters, but is there any way to avoid this? Can I force all granule to be processed under a smoothed (or constant) atmopheric model?



you can set in L2A_GIPP. xml file worth for visibillity ( VIS_Update_Mode>1</VIS_Update_Mode
!-- 0: constant, 1: variable visibility --) . Thats all what i now. Maybe it helps


I have the same problem. Kiryl23, can you specify more where is the XML file? Is it in the folder that we get after apply Atmospheric correction, into the granule folder? I tried to do that, but I cannot solve the problem.


The file L2A_GIPP. xml is the configuration file for many options of Sen2Cor. I would love to see a comprehensive documentation, but have yet to find one. On windows it is installed by default in %userprofile%\Documents\sen2cor\cfg\L2A_GIPP. xml

Hi oak,
Thank you for the answer. I did the change, but I continue with the same differences in the borders. Do you resolve the problem?

I did not find a way to resolve the problem.

I was also very wary to make changes in the L2A_GIPP. xml file. It is not clear what the config options actually do, and what effect this will have on data output consistency. Perhaps somebody knows if there is documentation somewhere?