Sen2cor DEM

Good morning everyone,
for my university thesis for the first time I’m using the forum for technical advise, I apologize if I’m expressing myself incorrectly.
I keep getting this error while processing a Sentinel-2 image with Sen2cor using the DEM and I can’t go forward.

File “C:\Users\pc owner.snap\auxdata\Sen2Cor-02.05.05-win64\lib\site-packages\osgeo\”, line 2835, in Open
_ return gdal.Open(*args)
RuntimeError: `C:\Users\pc owner\Documents\sen2cor\2.5\DEM\srtm_L2A_T32TNS_A014791_20180422T102115_src.tif’ does not exist in the file system,
and is not recognized as a supported dataset name.

I tried:

  • creating a folder DEM in sen2cor folder and as well in 2.5 folder
    -cancelling the folders DEM (in the folder 2.5 and sen2cor )
    -cancelling the two DEM downloaded which were actually downloaded correctly

But nothing seemed to work.
Thank you in advance

please have a look at this workaround: Sen2cor DEM parameters

The link you gave me does not apply to my problem:
I’m using sen2cor’s DEM, which are downloaded correctly and are in 2.5 folder so I don’t need to use my (or another) version of it.
If I plot “DEM” in the sen2cor window instead of “NONE” I get the message above.
If, instead, I leave the specific “NONE” it seems to work.

Now, when I start the process hitting the RUN button I get this message
…_in assignOzoneContent _
self.ozoneContent=min(columns, key=column.get)
Attribute Error: ‘NoneType’ object has no attribute 'get

and this window appears
“it sems there was an error on execution or the defined tool output error pattern was found. please consult the SNAP log file”

I closed it and re-run the whole thing and it worked.

I don’t know if these two thing are related or what but by adding the DEM I still can’t make it work.