Sen2cor DLL load failed

Hi all,

I am trying to apply atmospheric correction (Sen2Cor) to a Sentinel 2 image, however, at ever turn I take, a new error gets thrown at me.

I have finally managed to get Sen2cor installed and running(by installing anaconda - as the standalone version would not work). My problem now is that while it is running, the following error occurs:

ImportError: DLL load failed: The specified module could not be found. I have seen various topics about this, however none of the solutions have worked for me.

DLL load failed suggested upgrading Gdal and Numpy in the Anaconda Prompt as the solution. I did this but still get the same error.

Import_imaging as core; DLL load failed; specified module could not be found suggested upgrading pillow. This too did not work for me.

I have also tried uninstalling and reinstalling Anaconda and Sen2Cor. This didn’t help either.

Is there a solid solution to this problem yet as everyone seems to be getting the same error?


Hi! Checking your image i see that the process fails at the same step as mine. I wonder if you could fix it? I’ve being triying to make it work, but after solving a problem another one comes out. And as i really unknow programming lenguage this gets hard for me. I hope you can help me

Thanks in advanced