Sen2Cor does not start to process (and does not return any errors) is in “C:\Users\YourName)\Anaconda2\Lib\site-packages\sen2cor-2.0.6-py2.7.egg\sen2cor”. So basically in your Anaconda installation folder. If you are not sure with edting this file you can make a backup. Just create a folder somwehere on your computer (Desktop for example) and copy the file there. So in the case of destroying, you can always replace it with your backup copy to get back the original code lines again.

To get in to the you have to open it with your standard Notepad, or better: with Notepad++ (it’s free).
In Line 1380++ you have to replace the function like Christian explains it. The most important thing is that the indentation of the codelines is exactly like in Christians code.
After that: Safe the file and it should work.

you are working with an outdated version of sen2cor. Please use the new vesrion 2.2.1 from here: and read the release notes.
The problem with the windows oath names is fixed among lots of other issues.
There will not be any further support given on v.2.0.6.

Oh I did not know that, thanks very much! I will upgrade as soon as possible!

Hi umwilm,
I installed sen2cor 2.2.1 successfully and i have the same problem - after i tried to process Sentinel-2 Scene. Nothing happens and black console window appear.
Any idea how to proceed ?

Hi @ori.r
Plz did you manage to solve your problem ? Thanks ,D

I have the same problem using the sen2cor v.2.2.1 which I installed according to the default settings (i.e SNAP first, then anaconda according to the default settings, then sen2cor v.2.2.1 then integration of sen2cor in snap). The result is a black Processing screen which processes nothing… I will try the above suggestions by Omnishables and post back…

Hi Daniel,
Yes, i solve the problem according Omnishambles answer here - Sen2Cor does not start to process (and does not return any errors)


Hello everyone, despite all comments regarding a positive solution on the issue of “the black console window with no process”, I haven’t manage to get a solution myself. I still have the same problem and i’ve tried everything described for each one of you that appeared as a possible solution. Is there a clean way out to this problem? I have SNAP 4.0 and all new versions of Anaconda and Sen2Cor 2.2.1 installed and integrated. I left default paths to all environment variables. I also gave new paths after all error messages when started the tool at any resolution. I don’t know if i’m missing any step in order to get this thing right. Also, i moved the product close to C:.
I’d appreciate some help please!!

Best regards

I have the same situation, and have done for months. I updated SNAP to version 4. I followed the release notes for the latest Sen2Cor (update conda, update anaconda, unistall previous sen2cor, reinstall new version via command line, integrate with Snap), but although the processor starts, it fails after about 6 seconds, regardless of resolution. So frustrating - I’m sick of trying to get it to work and failing. I wish there was an option to obtain the products pre-processed as there is with USGS landsat data.

Hi, Reflectance, this is what I did and now Sen2cor is working:

I re-installed everything from scratch, changing two things from the very beginning :

  1. I assigned a path to python.exe from the anaconda install wizard at the beginning of the installation
  2. As I was installing SEN2COR I realized in the command prompt SEN2COR_HOME was assigned a path and that location was different from what I had set in my system variables, so I changed it.
  3. And the rest of my system variables look like this:

Now i’m trying to solve the 10m resolution issue of the correction. If you have any questions just let me know.

Good luck!

Thank-you junoangarita! I changed the location of the python_exe file to its true location and the processor worked a little better. It still didn’t complete processing on any of the resolutions however. Perhaps because I have only one tile stored instead of the entire L1C product (to save space)? I can’t get it to work from the command line either. I think I’ll wait until they change the product format to single tiles, then try again. As I said though, it’s a shame that acquiring BOA reflectance data from this beautiful sensor is so difficult (for some of us at least). Good luck with your 10m resolution issue.

I totaly back your opinion, it’s a total shame to have such a nice product and not be able to do anything with it. Try downloading the whole product, processing it and then erasing the rest you won’t need. I actually only work with one tile everytime cause never need a bigger scene. Check again all your variables, I also had problems with the sen2cor_home path try changing that too. It took me a month to solve only that. I guess ESA will have to find another image lab to work for them bcause these guys aren’t just doing things right, they’re not giving full support to users.
Good luck, if get to stumble upon the 10m processing error let me know.

Workaround for 10m processing:

I agree with you guys; it’s a pity that Sentinel-2 usage is impeded by the flawed sen2cor tool and its unattended bugs. It takes a lot of know-how and effort to get it running.
I have high hopes on @OHagolle and his team fixing the issue with the MACCS processing or sen2cor being replaced by another processing framework.

Thanx for the workaround unnic i’m gonna try that…

hey unnic, if there’s a newer workaround let us now, I think that used to work for the previous version of sen2cor since line 1380 does not look anything like what’s being suggested, I suppose it’s because i’m using a newer version of the tool.

Best regards

Thanks for your “high hopes”, Unnic !

I have to say that MACCS and SEN2COR were developed with different objectives, MACCS being a processor working only on specific unix platforms in a ground segment framework, and SEN2COR being a cross-platform software distributed to users.

Sen2cor works well on my linux computer, and seems to work on different platforms even if not all of them. I understand it is quite difficult to have it working in all sorts of platforms, in stand alone version or integrated to SNAP.

MACCS will not be used in the same way :

  • It will be used in Theia to produce L2A data over 5M square kilometers ( ).
  • It will be integrated in the Sen2Agri package that will be distributed in spring next year, but will require strong linux computer with Red Hat or Cent OS distributions,
  • and, together with DLR, we are trying to convince ESA to use it within its ground segment, but there is a long way to go.

THEIA should start distributing all the S2A data acquired above France before the end of this month. The release will be announced here :


ok, too bad because I need to run the process locally so MACCS seems to be out of the picture now. Many working environments don’t provide the opportunity to choose your own OS
I have to disagree with “Sen2cor work well”, at least on windows and ubuntu. If you take a look around in the forum you will see it’s true for others as well (i.a. 1 (the first comment summarizes the issues pretty well) 2 3 4 5 6…) Please note the absence of comments from the dev team. Issues we are discussing here are kown and often more than 8 months old and are still not adressed. sen2cor seems to be poorly- or even un-maintained.

I know that often you can’t choose, but it is such a pain and cost being flexible on environments.
Where is your ROI ? I gues it is not included in the zones processed by Theia ?

Sen2cor works on my ubuntu (14.04, 3 different computers), I did not try windows.
This post was processed on ubuntu ;

Unfortunately my ROI is not covered by Theia.
I know your blog and appreciate it, found some good info and inspiration on it, thanks!

Hello, what if SEN2COR_BIN or SEN2COR_HOME is not in my list. Do i simply just add it?