Sen2Cor doesn't appear in the external tools

Hi everyone,

I had installed the SNAP(old version) and then Sen2Cor(old version). i had have Python2.7 already installed in my pc (win10/64-bit), and in the beginning i had some problems to fix the path. Finally, i uninstalled my old Python2.7 and installed the Anaconda2-4.2.0 and i fixed the problem. Later, i tried to do an atm. correction and it worked.

Unfortunately, some days later, I tried again to applied the atm. correction, but it didn’t work. I realized that there were a new version of Sen2Cor-2.3.0 and also SNAP-5.0. However, I wanted to work with one the image that already had the atm. correction, and i started having problem with the masks.

So, at that moment i didn’t know what to do. and i chose to uninstall everything! and installed the new versions.
I didn’t have any problem in the second installation. Then I checked with the command line if everything was fine, without any problems or errors.
BUT, when I installed the sen2cor in the snap (tools-plugins-available plugins) and later reopen snap…I think that i have an error somewhere! because the Sen2Cor doesn’t work. i tried to edited in the external tools but Sen2Cor doesn’t appear! Now I’m confused.

I had read some topics in the forum and checked if i have errors in the installation or somewhere else. but I didn’t find a similar problem.
Could any one please tell me the error or what is I am missing?

Thanks! : )

I have the same problem, but now it’s solved, you have to uninstall Sen2cor and reinstall it in SNAP >> Tools >> Plugins



Hi! thanks for the answer! I tried but it not worked for me…
I also have read in the forum that depends if you have more than 8 GB of Memory RAM…but I did the installation in other pc (Win10/64bit/12GB RAM) and I still continue with the problem…

Do you have another idea!?

Probably my answer in this post helps.