Sen2Cor error - "SPACECRAFT_NAME"

Hi All

I am runing Sen2Cor 2.80 to do atmosphere correction on a single image. I get the following error:

INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: File “C:\Users\roryh.snap\auxdata\Sen2Cor-02.08.00-win64\Lib\site-packages\sen2cor\L2A_Config.py”, line 3669, in updateTiles
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: if self.create_L2A_Tile():
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: File “C:\Users\roryh.snap\auxdata\Sen2Cor-02.08.00-win64\Lib\site-packages\sen2cor\L2A_Config.py”, line 3694, in create_L2A_Tile
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: self.getEntriesFromDatastrip()
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: File “C:\Users\roryh.snap\auxdata\Sen2Cor-02.08.00-win64\Lib\site-packages\sen2cor\L2A_Config.py”, line 3635, in getEntriesFromDatastrip
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: self.spacecraftName = di.SPACECRAFT_NAME.text
SEVERE [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: AttributeError: ‘bool’ object has no attribute ‘SPACECRAFT_NAME’
INFO [org.esa.snap.core.gpf.operators.tooladapter.ProcessExecutor]: Finished tool execution in 4 seconds
WARNING [org.esa.snap]: Opening target product by guessing the plugin failed [null]. Trying by extension.
INFO [org.esa.s2tbx.dataio.s2.l1b.S2L1BProductReaderPlugIn]: Building product reader L1B Multisize…

i have tried my plugin on other images as well and get the same error. Any help would be greatly appreciated.

Rory

This looks like a metadata problem with the input file, so you may need to use a format with more complete metadata, or some earlier step has lost metadata.

It would be useful if you could provide enough detail to allow others to reproduce the issue, in particular, the input file.

Hi George

Thanks for the response.

The input file was tile: S2B_MSIL1C_20210905T071159_N0301_R020_T38KLV_20210905T090212.SAFE

The error log file is attached.

What bugs me is that I tried a different tile from another date and got the same error. I’ve never seen this error nor have a clue what it means.

Thanks,

Rory
messages.log (87.1 KB)

There ae already some threads regarding this issue.
Search results for ‘SPACECRAFT_NAME’ - STEP Forum (esa.int)
In some posts it is said that creating an empty AUX_DATA folder in the root folder of the data prodcuts helps. In other it is said that version 2.9 helps.
So updating sen2cor might help.

Thanks again. I uninstalled 2.8 and went back to 2.55 and it workjed like a charm. I suspect there is an issue in the latest update. Keep well and thanks for the assistance

Hi @rhickson Rory,

The latest version is Sen2Cor 2.9. The standalone processor (and supporting documentation) are available at: Sen2Cor v2.9 – STEP

Sen2Cor 2.9.0 (PSD 14.6]). Sen2Cor2.9.0 supports generation of L1C aligned with the current (14.6) and previous (14.5 and 14.2) as input. In response to another User who had issues with v2.8 and Baseline 03.01 production, we were able to process in v2.9 without issues.

Sen2Cor can be downloaded from Sen2Cor v2.9 – STEP

PSD 14.6 (and associated Schema) can be downloaded from the Sentinel Online S2-MSI Document Library: Sentinel-2 MSI Document Library - User Guides - Sentinel Online - Sentinel Online It is noted that the XSD schemas relative to Level-1A, Level-1B, Level-1C, and Level-2A products are attached to this document as a *.zipp attachment. The attachment should be saved, and renamed as .zip to enable it to be opened.

I hope this helps you.

Cheers

Jan

S2 MPC Operations Manager