Sen2cor - error

I have written some python code that runs Sen2Cor-02.10.01-win64. I execute the following code.

command = “{0} --GIP_L2A {1} --output_dir {2} {3}”.format(os.path.join(sen2cor_path, “L2A_Process”),
L2Axml_path, outpath, unzip_path)

I got the following error. Any idea how to fix it?

File “C:\Sen2Cor-02.10.01-win64\lib\”, line 512, in _read
raise MissingSectionHeaderError(fpname, lineno, line)
ConfigParser.MissingSectionHeaderError: File contains no section headers.
file: C:\Users\tensorflow\Documents\sen2cor\2.10\log.estimation, line: 1

Dear @iliasmachairas,

Thank you for your message.

In order to better understand your problem and to find if the error you are experiencing is strictly
associated to Sen2Cor, may we ask to run Sen2Cor via terminal with its basic command lines please?

Do you see the same error?

We also suggest to update the version of Sen2Cor to the latest available (2.11) that can be found here:
(Sen2Cor v2.11 – STEP)


Thanks for your answer. I tried the following one:

> C:\Sen2Cor-02.10.01-win64>L2A_Process.bat F:\\test_eshape\\01_UNZIPPED\\S2B_MSIL1C_20240128T092139_N0510_R093_T35TLF_20240128T100628.SAFE

but I got the same error. the same happened when I tried the following command:

C:\Sen2Cor-02.10.01-win64\L2A_Process --resolution 10 --output_dir F:\example_atcor F:\\test_eshape\\01_UNZIPPED\\S2B_MSIL1C_20240128T092139_N0510_R093_T35TLF_20240128T100628.SAFE

Dear @iliasmachairas,

Could you please test the same command with Sen2Cor version 2.11 ? Which is available here.

According to the error message you provided, it seems that you have an issue with the (hidden) file named .estimation.

This file is created during the initial run of Sen2Cor, right after installation. Its final purpose is to help providing an estimate of the Sen2Cor progression from 0 to 100%, based on an average processing time related to the user’s machine.

The file .estimation is located in SEN2COR_HOME\log, for example, C:\Users\tensorflow\Documents\sen2cor\2.11\log\, and typically looks like this:

[time estimation]
t_est_60 = 150.0
t_est_20 = 394.535816917
t_est_10 = 1649.47790634


I used Sen2Cor version 2.11 and it worked like a charm. I also tried the changes you suggested regarding .estimation and sen2cor 2.10. It worked too. Thanks for your help and quick response!

Can I use Sen2Cor version 2.11 for all images of all available years (e.g. 2020, 2021, etc) or is this only applicable to one specific period?

1 Like

Dear @iliasmachairas,

We are glad to hear that your issue is fixed.
We can confirm that you can use this version 2.11 to process all images of all available years (e.g. 2020, 2021, etc). Please have a look to point #14 of the Sen2Cor FAQ.


1 Like

when I manage to make the correction with sen2cor I receive this message that there is an error in the access path but for other images everything works fine

Dear @ayoubdaiz,

The issue @iliasmachairas has been succesfully solved. For the issue you experienced we suggest that you retry your processing with Sen2Cor version 2.11. It your issue persists please create another ticket.