Sen2cor failed to work

Hello everybody,
I just install sen2cor in windows 8 and when I tried to process an image band 1 (60m ) with the tool the atmospheric correction was not performed and I got the following message :
Process exited with value 2
Have you got any idea about this message ?
PS: I installed correctly anaconda 2,7 and sen2cor 2.2.1 was tested and worked.

Hello buendia,

Did you get this issue solved? I am running into the same issue.



Could you please attach a screenshot of a command line execution of L2A_Process?

hello forum community,
actually I stopped trying installing Sen2cor in windows and I tried in ubuntu 14.04.
This time I got the 60m and 20m bands working but when u tried sen2cor for the 10m resoution i got the following result:
no scene classification processing for 10m resolution in sc_only mode.
Anybody faced the same problem of mine?


Hallo buenida,

do you tried to process a single band with Sen2Cor? Can you please give me some more information about your processing configuration?

Scene classification is only performed with 60m and 20m resolution.


hallo bdpg,
I attach a screenshot of what is the result of the application of sen2cor to a 10m resolution scene.
I simply process a tile of S2 with the sen2cor GUI at 20m and 60m with success in fact a also obtained the scene correctly classified, but i received an error message when I process the 10m. No I have not tried to process a single band, by the way is that possible in SNAP? Na d how?
Many thanks for your cooperation

hallo everybody,
I also tried the script L2A_Process but I found another problem on processsing 10m resolution bands.
The following part shows the problems encountred by the script:

L2A_Process --resolution 10 S2A_OPER_MSI_L1C_TL_SGS__20160618T170951_A005167_T32TPT_N02.04

Sentinel-2 Level 2A Prototype Processor
(Sen2Cor), 2.2.1, created: 2016.04.29 started …
Traceback (most recent call last):
File “/home/filippo/anaconda2/bin/L2A_Process”, line 11, in

load_entry_point(‘sen2cor==2.2.1’, ‘console_scripts’, ‘L2A_Process’)()
line 236, in main
result = scheduler.sync()
File “/home/filippo/anaconda2/lib/python2.7/site-packages/sen2cor-2.2.1-py2.7.egg/sen2cor/”,
line 46, in sync
p= L2A_ProcessTile(tile, self._res, self._msgQueue, self._queue)

line 46, in init
stderrWrite(‘Cannot load configuration\n.’ % picFn)

TypeError: not all arguments converted
during string formatting

I am wondering if Any of you had similar error messages.

Hello community,
I tried another time the 10 m sen2cor processing without success.
Here you can read what was written in my Sen2Cor_Level-2A_Report_File.

<?xml version="1.0" encoding="UTF-8"?>


logging for the main process

validating metadata file L2A_CAL_SC_GIPP.xml
against scheme

metadata file is valid

validating metadata file L2A_CAL_AC_GIPP.xml
against scheme

metadata file is valid

validating metadata file L2A_GIPP.xml against

metadata file is valid

No metadata in datastrip.

subdirectory in datastrip

no scene classification processing for 10 m
resolution in sc_only mode

no scene classification processing for 10 m
resolution in sc_only mode

validating metadata file
against scheme

Schema file:

Details: Element
Missing child element(s). Expected is ( Image_Content_QI ).

validating metadata file against

metadata file is valid


Hello everyone. PLEASE HELP ME. I tried installing sen2cor according to the recommendations using anaconda2. But when I run I get the information: python does not exist: python.exe. Sorry, my English is not very good.