SEN2COR_HOME - unrecognized variable

To Whom It May Concern:

I have been trying to run sen2cor using the python command line interface (Anaconda) and I get the following message (see below). I tried to correct this bug by remaking the SEN2COR_HOME directory (according to the instruction manual). I then sought help from somebody who knows python and they tell me that sen2cor doesn’t even seem to recognize that this variable even exists.

Can anybody offer me guidance on how to correct this problem?

eduroam-169-233-198-220:~ jessebausell$ L2A_Process S2A_OPER_PRD_MSIL1C_PDMC_20140915T120000_R069_V20091211T165928_20091211T170025_01_V12_2011 --resolution 60
Traceback (most recent call last):
File “/Users/johnsmith/anaconda/bin/L2A_Process”, line 9, in
load_entry_point(‘sen2cor==2.0.4’, ‘console_scripts’, ‘L2A_Process’)()
File “/Users/johnsmith/anaconda/lib/python2.7/site-packages/sen2cor-2.0.4-py2.7.egg/sen2cor/”, line 233, in main
processor = L2A_Process(directory)
File “/Users/johnsmith/anaconda/lib/python2.7/site-packages/sen2cor-2.0.4-py2.7.egg/sen2cor/”, line 21, in init
self._config = L2A_Config(workdir)
File “/Users/johnsmith/anaconda/lib/python2.7/site-packages/sen2cor-2.0.4-py2.7.egg/sen2cor/”, line 27, in init
self._home = os.environ[‘SEN2COR_HOME’] + ‘/’
File “/Users/johnsmith/anaconda/lib/python2.7/”, line 23, in getitem
raise KeyError(key)
KeyError: ‘SEN2COR_HOME’

Hi JessturB,

which OS are you using? I followed these and these instructions and it worked perfectly fine. I am using Ubuntu 14.04 LTS.

Maybe that helps you a bit.