Sen2Cor installation failed

I am trying to install Sen2Cor for SNAP 9.0.0 on my MacBook. I have tried different versions, but all of them failed at the bundle install step. Any help or suggestion would be really appreciated! :pray:

Below is the log file
messages.log (90.3 KB)

This problem was fixed.
I downloaded the installer from Sen2Cor v2.8 – STEP.
And used local install instead of remote, and the installation was successful.

The error for the failed attempt was:

SEVERE [org.esa.snap]: Failed to load clusters file from '/Applications/snap/etc/snap.clusters'

Since your local install worked, the mentioned file must exist, so this looks like a permissions problem. You didn’t mention your MacOS and Sen2Cor versions. Apple has been restricting remote content for security reasons, and (from the 2.11.0 Release Note):

Mac: this release does not support a Mac version for Sen2Cor 2.11.00. Further updates on the availability of a Mac version will be released in the future.

An older version of Sen2Cor may be fine for learning, but for serious work you need to check that your results agree with 2.11.00. If you don’t have access to a linux system you can use a VM in MacOS or install linux to an external drive.

Thanks for the reply gnwiii.
MacOS: Monterey 12.3.1
Sen2Cor: 2.8.0
I will also install the latest version Sen2Cor 2.11.00 as well.

I do have snap.clusters on my laptop, so I was confused by the message.

SEVERE [org.esa.snap]: Failed to load clusters file from '/Applications/snap/etc/snap.clusters'

It seems that there is no installer for MacOS yet for Sen2Cor 2.11.00. Will there be a standalone installer for Mac in the future?

Hi gnwiii, I checked on SNAP 9.0.0 to find Sen2Cor 2.11.00. In the Available Plugins, I couldn’t find Sen2Cor 2.11.00. In the Installed, I have Sen2Cor, Sen2Cor280, Sen2Cor 290, where I only installed the binary bundles for 2.8.00 using downloaded The Sen2Cor seems to be 7.0.0. Am I doing something wrong to check for the latest version 2.11,00?

Hi @hyan,

The Sen2Cor 2.11.0 plugin is not yet available in SNAP.